0

I have iPhone 4 and my iOS is 4.10.01. I jailbroke it and installed a lot of applications. Being lazy to reinstall everything again every time after an upgrade, I decided to just leave it at iOS 4.10.01. It worked fine for a while but as new iOS versions came up, many of the applications I installed stopped working. I didn't care much for this as long as Cydia and my packages were working all right. However, at some moment the Cydia icon just disappeared, and I don't remember deleting it, though the installed packages continued working fine.

Yesterday, I wanted to update one of the packages as it wasn't functioning correctly. Searching the web for a method to restore Cydia without affecting applications suggested a method, which I tried. However, this failed and all the packages I installed were gone. Trying to reinstall them resulted in multiple errors being returned by Cydia.

I decided that it might be better to update iOS for the last time and start over, but that doesn't seem to be an option. The "update" option in Settings isn't there, and iTunes fails to be recognise the iPhone. Reinstalling iTunes multiple times does not seem to rectify the issue. I've also tried all my USB ports, along with iFunBox. As of now, I can browse media from my computer, but that's as much as I'll get.

What is causing me to not be able to restore my iPhone?

1

To restore your iPhone, boot it into recovery mode and wipe it from there.

To boot your iPhone into recovery mode and restore it to the latest version of iOS supported by your iPhone:

  1. Shut down your iPhone by holding the lock button.
  2. Connect the USB end of your connection cable (presumably 30-pin by your software) to your computer but not to your phone.
  3. After the iPhone is off, hold the home button as you plug in the 30-pin connector.
  4. Your phone should start and iTunes should detect "an iPhone in recovery mode that must be restored before it can be used with iTunes".
  5. Restore to the latest version of iOS that is supported by your iPhone (by iOS 4, I would assume an iPhone 3G, which supports versions of iOS < 4.2.1)
  • You mean to connect it in DFU mode? – Cain Nuke Apr 13 '16 at 10:16
  • Yes. DFU mode is what you'd like to try with this. – perhapsmaybeharry Apr 13 '16 at 10:16
  • I did that already and iTunes wont detect it. I have tried in both normal mode and DFU mode but I cant make iTunes or iFunbox detect it. However, I can see my media from My computer. I forgot to say I have Windows 7. – Cain Nuke Apr 13 '16 at 10:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .