Hi I've just installed ZSH and it looks awesome but git icons are still missing and I don't know what I miss.

enter image description here

What I should do?

  • Which them are you using? – ChickenWing24 Apr 11 '16 at 6:49
  • amuse at this moment but I've tried with agnoster but there was more missing icons. If this is important I'm running on os x 10.11.4 – Błażej Apr 11 '16 at 6:52
  • Have you tried to re-install it? Not much of a technical solution, but that might just do trick. – ChickenWing24 Apr 11 '16 at 7:11
  • How to do that? – Błażej Apr 11 '16 at 7:35
  • 1
    @Dudi that update should be an answer not an edit – user151019 Apr 11 '16 at 9:18

Missing icons in this case a patched font isn't installed which is dedicated for showing specific symbols for your shell.

You can either set yourself up easy with an available repo. I should note that these patched fonts are for the Powerline extension and may or may not be compatible with other extensions.

If you wish to patch your own font, however, it's a little more involved:

  1. Download fontpatcher
  2. Using a package manager such as homebrew, install fontforge (brew install fontforge).
  3. Patch your fonts by running the fontpatcher script like such: fontforge -script /path/to/fontpatcher.py MyFontFile.ttf
  4. Update your terminal configuration to use the patched font.

Turns out I didn't have powerline font.

You can get it from here

After download, double click to install and set as defalut font & non-ascii font

  • Can you expand on this e.g. where you get it from – user151019 Apr 11 '16 at 9:27

It worked for me when I unselected the option in iterm preferences to use a different font for non-ASCII text.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .