0

Screen sharing through the app has been shoddy at best for me since updating. I thought I had it figured out and now its not working this week. My device on the same network is a linux machine and connecting to it from ssh works fine (always has). But for whatever reason the screen sharing functionality is Broken. I’ve tried to connect to server using vnc://x.x.x.x or smb://x.x.x.x as well as without the slashes.

This Usually Works

I’ve tried to connect using the Screen sharing app as well. There is a weird 3rd option that sees my computer but it NEVER works to connect to it.

This Never works

So Far I’ve tried to restart the machines and this:

http://forums.macrumors.com/threads/if-your-screen-sharing-stops-working-read-this.441030/

Summary says:

  1. Launch the Activity Monitor program.
  2. In the Process Name list, look for "NetAuthAgent". It may show as "Not Responding".
  3. Select NetAuthAgent, and then click Quit Process (the red stop sign button at the top of the Activity Monitor window). Then, click Force Quit.

Your Screen Sharing should now work.

But that is from 2008 so I know there’s no way that they didn’t fix that by now.

Bottom Line: How can I fix screen sharing to this other device, for Good?

1

On your Linux computer you will need a to run a VNC server of some sort.

There may be one already installed that you need to start. How to do this depends on the Linux distro you have. Try man vncserver at the command line on the Linux box and see what you get.

VNC is a screen sharing protocol and SMB is a file sharing protocol so you can't get screen sharing using SMB.

  • ah, thanks for explaining that. I've got one, its built in (mint Linux) but it seems to work inconsistently, yet I can login flawlessly with ssh between restarts. If I could somehow start the vnc server via ssh that would be ideal – Frankenmint Apr 13 '16 at 4:33
  • Well you should be able to do that. You just need to know what the VNC server software is and it should be easy to start it from the shell after you ssh in. I suggest you ask your question in the Linux area of Stack Exchange - "How do I restart the VNC server from shell?" – Tony Williams Apr 17 '16 at 21:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .