3

In my iMac 21.5-inch computer (OS X El Capitan Version 10.11.1) I have a cordless keyboard.

At the top of the key 6 I have ˆ instead of ^.

This is a problem. I never have needed to use ˆ, however ^ I need to use it very often. For example, formatting formulas at Math Stack Exchange with MathJax.

Therefore I need to look it up in the Internet.

Is there a special shortcut for having an input of ^? Or is there a way to change my keyboard inputs?

  • Does Shift+6 not bring up ^? – perhapsmaybeharry Apr 9 '16 at 15:56
  • @perhapsmaybeharry No. It brings me up ˆ. But in the keyboard it has the figure you say. – Pichi Wuana Apr 9 '16 at 15:59
  • That's really weird. What keyboard format do you use? – perhapsmaybeharry Apr 9 '16 at 16:00
  • @perhapsmaybeharry What do you mean? I use this keyboard, if it is what you are asking. – Pichi Wuana Apr 9 '16 at 16:06
6

You need to go to Keyboard Preferences and add a new keyboard.

Instead of using USA International keyboard you will need to use USA Keyboard.

So from

enter image description here

Use instead

enter image description here

  1. When you are going to add a Keyboard you select English.
  2. At the end of the list you will see both keyboards. Use the one that is not international.

enter image description here


Another option is to put the ˆ and before you press another key, press the space bar.

  • As suggested by Pichi Wuana, add the USA Keyboard instead of USA International Keyboard and don't forget to remove previous one USA International Keyboard – anuj kumar Dec 27 '18 at 6:47
0

You can find the combinations to many more symbols by opening "Keyboard Viewer".

The combinations in here should reflect your current keyboard layout as specified under System Preferences > Keyboard.

To open Keyboard Viewer, click the menubar keyboard icon (if you don't have it, it's enable it from System Preferences > Keyboard) and select "Show Keyboard Viewer".

I suggest pressing Option or Shift or Option+Shift to modify the keyboard input under Keyboard Viewer.

  • 1. I get this where you told me to go. 2. I can't do replacement of shortcuts that have less than 2 characters. – Pichi Wuana Apr 9 '16 at 16:05
  • For point 1, look under the first tab, last option, for two, good point. I suggest looking at keyboard viewer to identify where ^ actually is. I must've overlooked the two-character minumum – perhapsmaybeharry Apr 9 '16 at 16:07
  • Oh! I resolved it. It was changing from English International Keyboard to English keyboard. I guess I answer my own question? – Pichi Wuana Apr 9 '16 at 16:10
  • Sure. I just went and looked under "English International - PC" and I understand why it didn't work. – perhapsmaybeharry Apr 9 '16 at 16:11
0

Just hit space bar after you have typed down ˆ and you will turn it into ^.

  • 1
    This solution is already included in the top answer from 3 years ago. – Tom Gewecke Jun 25 at 14:15
-2

Try pressing Alt + I That's an 'i', not a lowercase L 'l' or '1'. If that doesn't work, switch to a new keyboard.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .