0

I have an iPhone 5c running iOS 9.3.1

Why does iMessage only give me sound and alerts when a message comes from a phone number and not when it comes from an email address?

  • How is the sender sending the non phone messages? – mmmmmm Apr 8 '16 at 15:18
  • Welcome to Ask Different. could you edit this to correct my assumption on your version if needed? Also - are you aware of the do not disturb setting that can be enabled for a thread as opposed to the entire app/system? – bmike Apr 8 '16 at 15:32
1

On the iPhone go to Settings --> Notifications --> Messages and make sure the following are all turned on, depending on what you want:

  • Allow Notifications
  • Show in Notification Center
  • Sounds --> <select sound>
  • Badge App Icon
  • Show on Lock Screen

Under Alert Style When Unlocked select either Banners or Alerts, depending on how you want to be alerted.

As mentioned by @bmike, your Do Not Disturb setting will affect if the alerts go thru or not.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .