1

I just upgraded from Mavericks to El-Capitan. Upon attempting to log in to my profile, the login process gets stuck at the spinning load graphic, until I am forced to shut down. It appears that disabling SIP has fixed the issue, and the login took less than 5 seconds.

Why is this?

I suspect some kernel extension doing this, so I searched with sudo kextstat | grep -v com.apple to see the non-apple kexts. Here is a list:

Index Refs Address            Size       Wired      Name (Version) UUID <Linked Against>
  142    3 0xffffff7f83017000 0x5f000    0x5f000    org.virtualbox.kext.VBoxDrv (5.0.6) FB8B8CAC-638F-3853-9CF3-5A0229B47B68 <7 5 4 3 1>
  143    0 0xffffff7f83076000 0x14000    0x14000    com.intel.kext.intelhaxm (6.0.1) 8FF2C637-0A5E-367E-B007-5B08655B1E8A <7 5 4 3 1>
  144    0 0xffffff7f8308a000 0x9000     0x9000     net.telestream.driver.TelestreamAudio (1.1.0) EEF9313A-72D9-F5C7-7408-F1F8F3E37A2C <104 5 4 3 1>
  150    0 0xffffff7f82467000 0x6000     0x6000     com.logmein.hamachi (1.0) 57549AD3-8860-C370-448E-68D7E6EBC0DA <7 5 4 1>
  152    0 0xffffff7f83093000 0x8000     0x8000     org.virtualbox.kext.VBoxUSB (5.0.6) 0585ED0B-8D0D-3F96-8BF9-EA50FB281D2A <151 142 41 7 5 4 3 1>
  153    0 0xffffff7f8309b000 0x5000     0x5000     org.virtualbox.kext.VBoxNetFlt (5.0.6) C5D7E667-CAFE-3B85-AE60-441006FB2BC0 <142 7 5 4 3 1>
  154    0 0xffffff7f830a0000 0x6000     0x6000     org.virtualbox.kext.VBoxNetAdp (5.0.6) 1A232B48-34B8-3B06-8963-662FD1DE7542 <142 5 4 1>
  • 1
    VirtualBox may not be compatible with El Capitan: Prerequisites on Mac OS X: 10.6.x (Snow Leopard), 10.7.x (Lion), 10.8.x (Mt. Lion), 10.9.x (Mavericks) or 10.10.x (Yosemite) running on Intel hardware. From the build instructions page. – IconDaemon Apr 7 '16 at 13:58
  • @IconDaemon I got rid of all except telestream and intel kexts, and the login issue was gone. Either this, or it could be because of a NVRAM and SMC reset. Please post the comment as an answer – TheBro21 Apr 7 '16 at 17:56
2

VirtualBox is not compatible with El Capitan. From the VirtualBox build instructions page:

Prerequisites on Mac OS X: 10.6.x (Snow Leopard), 10.7.x (Lion), 10.8.x (Mt. Lion), 10.9.x (Mavericks) or 10.10.x (Yosemite) running on Intel hardware.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .