0

I have OSX Server 5.0.15 running and am having trouble getting Windows 7 clients to connect to share via SMB. The file server is running and SMB is turned on. Accounts and groups are set up. The users are accessing the server by ip address.

They can connect to the share but when asked for their username and password the password always get the error "the specified network password is not correct". I have even tried logging in with my credentials and I am an admin on the server.

I have used DOMAINNAME\username for the login to ensure they are logging into the proper domain. But no luck. I assume at this point that I am doing something wrong.

On the server the host name is server.local and the computer name is MacProVtrack according to the Server Overview tab. I am working from the premise that the domain would be "server". (see Screenshots)

Is the server or domain name not correct? Do I need to change the host name? Any help would be greatly appreciated.

connecting to server via IP

[user credentials while specifying domain2]

error

  • Edit: Just to add further clarification to the question, this was working under Windows XP and when they moved the clients to Win 7 it stopped working. The share works fine and always has for our Mac clients. – Izzy Apr 7 '16 at 22:35
1

I assume the OS X Server is not integrated in your AD environment. Then all credentials (user name/password) have to be set up on the OS X Server - at least as network account. Additionally all OS X Server shares have to be set up properly.

Then you have to enter the IP address and the name of the share (e.g. \\10.10.1.12\Data-User1).

The proper credentials in the Windows Security dialog are then: the user name and the user password (e.g. User1 and Passw0rd).

server\User1 only works if the OS X server is part of Active Directory and has the fully qualified domain name server.sld.tld (or in your case server.unionsupply.net).


server.local is no domain name but a qualified mDNS name in the link-local domain .local. This isn't intergrated in a common DNS environment.

  • Thanks for your feedback, our IT department does not support our OSX Server so we are not bound to their active directory.But I may put in a support ticket to see if they can tell me what to do on our end to remedy that. This was all working until they moved everyone from XP to Windows 7. And now none of the Windows clients can browse our server. – Izzy Apr 7 '16 at 22:32
  • @Izzy I have tested the above solution with a OS X 10.11 Server and a Windows 7 installation and it worked without further modifications. – klanomath Apr 7 '16 at 22:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .