3

I would like to disable the switching animation when switching the desktop in mac os El Capitain. Do you know how to do that?

Thank!

4

There is a program named TotalSpace, that has the feature you need. Once installed, you should open it up, go into "Transitions" and disable "Use transitions", this will remove the animation you get when you switch Workspace (aka Dekstop)

If you're on OS X 10.11.x El Capitan or later, you will also need to disable a feature known as "System Integrity Protection" which prevents you to edit or access system files. To disable it:

  1. Restart the Mac, then boot it in recovery mode, by holding down cmd (or Windows key) and R keys, before hearing the sound of your Mac startup. Hold them down for 5 secs.
  2. Click on "Utilities" on the top of your screen, then select terminal.
  3. On the new opened window, enter csrutil enable --without debug .
  4. Reboot
  5. Enjoy :)

csrutil enable --without debug is the better solution suggested by [http://totalspaces.binaryage.com/elcapitan][totalspace].

  • 1
    Note: TotalSpaces2 versions 2.3.5 and above have support for El Cap but cannot run on a normally configured machine due to system integrity protection. See: totalspaces.binaryage.com/elcapitan – kkurian Sep 7 '16 at 3:56
  • Well, not hard to disable it – Manchineel Sep 8 '16 at 21:09
  • Upvote still for the suggestion – Manchineel Sep 8 '16 at 21:10
  • Sure! AFAIK this is the best solution out there however imperfect. – kkurian Sep 8 '16 at 23:27
  • 2
    @David天宇Wong after you made the change it can be reenabled – Manchineel Jun 17 '17 at 10:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .