1

This question already has an answer here:

I have 15 inc Mac book pro with Mavericks installed. I can successfully on the Mac but I cannot login to my account. Upon press enter I get progress bar and after that I get grey screen then nothing happened.

I tried all those online solution i.e press cmd + s and follow:

/sbin/fsck -fy / /sbin/mount -uw / mkdir /Disabled_System_Library_Extensions cd /Disabled_System_Library_Extensions mv /System/Library/Extensions/ATI* . mv /System/Library/Extensions/AMD* . touch /System/Library/Extensions exit

But I have no luck resolving this issue (this is the second mac that happened). I can sure see both Hard drive (HDD) and see all the context in by using cd, ls etc.. commands in this mode.

I have also try changing the HDD that contain new OS (EL Capitan) but its the same old issue (also tried cmd+alt+p+r too). When I press Alt on startup I can see the HDD, so I guess the laptop can read HDD but cannot access it?

One things I have also noticed is that I cannot start anything and what I mean by this is if I press cmd + R to access disk utility I persist same issue, if I try installing new OS via USB i persist same issue. AND sometime when I login and keep the laptop for few long then my screen turns blue which forces me to restart my computer and follow the same procedure.

It will be nice if someone can help, can access var/log via cmd + S, if anyone requires specific log let me know.

marked as duplicate by bmike macos Dec 16 '16 at 21:44

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

If you're able to boot to the installation drive (external USB, DVD, etc.) but not able to boot from an internal drive, that indicates a hardware problem, likely with the drive or the cable attached to it.

An easy test is to attach your internal hard drive externally with something like this. If it boots fine externally, you can be fairly certain that there's an issue with the cable (or, less likely, the Logic Board).

If you still have trouble when it's connected externally, then you should first try reinstalling the OS while it's connected externally (as you might still have some software corruption). If it persists after that point, you likely have a bad hard drive.

  • what do you mean by boot. Using my internal HDD i get stuck on progress bar and if I use a USB to install a new OS I get same issue. If I change a HDD I get same issue (new HDD with latest OS) – tranmaster Apr 6 '16 at 17:26
  • Is this happening when you load up the OS installer? That is, can you even get to the installation screen? If you can't, then there's something more serious going on - likely a Logic Board issue or bad RAM. You can try booting with a single stick of RAM at a time (if you have removable RAM) and see what happens. I also recommend trying the individuals sticks in each slot, to make sure it's not a particular RAM slot that's bad. If that doesn't work, you should take in your computer for repair. – mcmahoniel Apr 6 '16 at 17:42
  • I can't get to the installation screen, so once i plugin cmd+R the progress bar appear then the screen goes grey and the mac freezes. I tried RAM suggestion i don't think thats the issue because the computer boots fine its just once i enter my password it cannot load a operating sys. – tranmaster Apr 7 '16 at 14:37
  • One symptom i have released is when the progress bar get stuck the light in the front of the laptop (small light on right) lights up (solid white) means the laptop went to sleep or hard drive crash i guess? – tranmaster Apr 7 '16 at 14:58
  • If the installer isn't loading, there's a major problem. Being able to load up the installer means you were able to load up a standard, basic, minimal OS. If that can't happen, there's a problem with the computer. As for why you are able to enter your password - are you running FileVault? If so, you get a password entry prompt as soon as you turn on the computer, but prior to the OS actually loading. – mcmahoniel Apr 7 '16 at 15:46
0

Could be due to kernel extensions you have installed, I had the same issue and posted a blog tutorial on troubleshooting and fixing something like that:

https://smyl.es/how-to-fix-mac-osx-stuckhanging-on-progress-bar-will-not-boot/

Not the answer you're looking for? Browse other questions tagged .