I can't download (update) files in iCloud Drive on my iPhone 6 over 4G connection. It only works with WiFi. Can someone help me? Thanks.


Please see this image which shows you how to enable cellular data.

enter image description here

Source: http://www.imore.com/how-enable-or-disable-icloud-drive-syncing-over-cellular

  • On iOS 12, this "Use Cellular Data" toggle has moved to: Settings > Mobile > iCloud Drive (near the very bottom, after the toggles for individual apps). – Hoylen Oct 14 '18 at 23:20

This happens when cellular data for iCloud is switched OFF:

  1. Go to Settings
  2. Select Cellular
  3. Scroll down to the bottom and switch ON the ICLOUD

By doing this, you can now download files from iCloud using cellular data.


I had the same problem on my iPhone8 and got it resolved with Apple Support. Apparently, while the settings (mobile data on, iCloud enabled) may be correct, the phone may not detect them correctly. The solution is to turn mobile data off, shut down the phone. Start the phone up again and then turn mobile data back on. Shutting down the phone must be done differently for this to work. Press volume down, press volume up, then press and hold the power button until the apple logo appears.


The way I solved that issue is to logoff and login from icloud and turn plane mode on for 30s. See https://discussions.apple.com/thread/8246057.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .