I am getting an error while installing OS on Virtual Box machine, that there is not enough free space as shown in the image. I allocated 20GB while setting up virtual machine, and 8.8GB is what apple says that I need here

enter image description here

I went to disk Utility->Disk Utility of VirtualMachine and tried changing partitioning of the VM. It cant be done. It also shows the instructions I need to take, but the "Enable Journaling" command is greyed out. What could be the problem?

It also says I am using CD ROM media, but I am not. The El Capitan iso file, that was linked to VM in the Storage tab of setting up VM, is on Desktop.

These are the screenshots for better illustration.

enter image description here enter image description here enter image description here

  • Yes, you are correct.
    – sanjihan
    Apr 5, 2016 at 10:56

3 Answers 3


By accident I tried to install OS X to the OS X Installer DVD iso file (mounted to the virtual VBOX CD-ROM device) itself.

Erasing/partitioning the VBOX HARDDISK disk (see images in question) and creating a new HFS+ Journaled formatted volume seems to work.


I erased the partition VBOX HARDDISK while naming it "UsableDisk" and rebooted the virtual machine.

This time I could see "UsableDisk" as an option on "Install OS X" screen as shown above. Choosing it to install the the OS X resolved the issue. Took around 15 minutes for install to complete.


What sanjihan said is right. But I didn't understand because it's my first time that I'm installing the macos. I find a video tutorial for solving this issue in here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .