2

For years, I've been able to ssh into a linux host and then (using an ssh option like ‑L5902:127.0.0.1:7898) tunnel a VNC connection from my mac; I've also similarly tunneled VNC connections to other macs. In both cases, I was then able to use Screen Sharing to connect to the remote system and work normally (remote mouse and keyboard control were present).

After updating to El Capitan (10.11.4) from Mavericks and finding the new Screen Sharing app, I re-established ssh connections to my linux and mac targets. Connections to another Mac work fine (I'm able to switch back and forth between "Observe" and "Control" modes). However, my linux sessions are now read-only ("Observe Mode"). The option to "Switch to Control Mode" (under the "View" menu) is greyed-out; similarly, the "Control Mode" (arrow in a target) icon on the session window is greyed-out and unresponsive to clicking).

Is there some trick to get Screen Sharing to allow "Control" access to a linux VNC host?

[After experimenting some more, I discovered that if I held the control key while opening the Screen Sharing app, the default initial mode for new connections changes to "Control". In the case of the linux sessions, there appears to be no way to change the mode once the connection is established. This change in the Screen Sharing's default appears to be permanent -- subsequent app invocations (even to new destinations) are created in "Control Mode". There are no obvious new/changed plist files corresponding to this change to "Control", so I'm not sure if there was some crufty pre-El-Capitan configuration causing the default "Observe" or if there is some other parameter storage mechanism for Screen Sharing.]

You must log in to answer this question.

Browse other questions tagged .