3

I use Fluid to separate my Jupyter notebook into a separate app instead of a browser tab, which makes navigating between the browser and the app easier. This used to work perfectly, until (it seems) the last update of Fluid (current version is 1.8.5 (184)).

When I open the app, which has its home page set to http://localhost:8888/tree, a Google search page shows up for that URL, instead of the URL itself.

Fluid app when opened:

Fluid

When I open the same URL in Safari, it shows the page perfectly:

Safari

From that I think I can conclude it's not an access issue.

Here's how the app was created:

Creation

And here are the general preferences of the resulting app:

Fluid general preferences

What I've tried so far:

  • Deleting the app and creating a new one (once with the same name and again with a different name)
  • Replacing localhost in the URL with 127.0.0.1

Version info:

  • OSX 10.11.4
  • Fluid 1.8.5 (184)

Update

I tried once more creating a new app with the IP address instead of the localhost hostname, and it worked.

One other thing I noticed is that with the original URL, this appeared in the web server's log:

[W 18:00:05.094 NotebookApp] 404 GET /tree.com (::1) 5.26ms referer=None

It seems that Fluid is appending .com to the URL, which doesn't resolve and which might have triggered the fallback to Google Search.

  • Also looking for a solution to this. Have different local apps, different local addresses, they can not all be on localhost. :| – Alisso Jun 28 '16 at 21:56

You must log in to answer this question.

Browse other questions tagged .