13

I've had this problem before and can't recall how I managed to fix it last time. I use Apple Mail to access my Gmail and normally flagged emails show up correctly. Starred emails in Gmail equate to flagged emails in Apple Mail and I can unflag an email in either Gmail or Apple Mail and it works.

But now I've got four emails that I can't unflag. They're not flagged in Gmail at all (although they used to be). When I see them in the Flagged folder in Apple Mail, they don't even have flag icons next to them but they're still counted in the number showing next to "Flagged". If I manually re-flag them and then unflag them, they disappear from the Flagged box. But then if I click into Inbox and then back into Flagged they show up again.

Any ideas about how to make these guys disappear for good?!

15

Simply delete the e-mail entirely, then move it from the trash back to a folder (or the inbox). There should be no more flag.

  • This works. This bug is f stupid, and Apple should fix it, for f sake. – Sibbs Gambling Aug 5 '18 at 22:41
5

Here's one approach I found that appeared to work:

  • For each flagged email that won't sync
    • Mark it as "red" flagged in the Flagged folder (it should show in the Flagged folder even though it doesn't have a flag next to it)
    • A red flag appears next to the message
    • Clear the flag on the message
    • The number of messages in the Flagged box should be reduced by one
    • Fully quit Apple Mail (Cmd-Q)
    • Restart Apple Mail and the flagged message should remain unflagged

Note: you can select all the emails in the "flagged" folder at once and do this en masse.

As user @ohcibi confirmed, you must force quit Apple Mail for this to work.

Followup: I just ran into this issue again and this process didn't solve it. I believe it may be related to the "Important" tag that Gmail adds. I went into Gmail and unmarked the message as being "Important", and then followed this process. That fixed the problem.

  • 1
    The important part is to cmd-q apple mail. I tried the same approach without quitting mail and those pesky mails won't vanish (while the counter still decreases). – ohcibi Dec 12 '16 at 10:19
  • @ohcibi Thanks for the update! I'll highlight that aspect in the answer and add a note. – aardvarkk Dec 12 '16 at 16:04
  • 1
    Do you mean "Force quit" (from Apple Menu->Force Quit), or "Quit" (command-Q, or Mail -> Quit Mail) ? – Neal Young May 21 '17 at 20:26
  • @NealYoung The second -- my wording wasn't clear and I'll adjust it. – aardvarkk May 23 '17 at 19:21
  • 1
    Removing the "Important" label also fixed this issue for me. Also if you don't care about the "Important" label you can go into Gmail's settings (in the web interface) and uncheck the box that says "Show in IMAP" for that label. To do that click the Gear icon in Gmail, select Settings and then choose the Labels tab. You uncheck the box on that screen. – RunnerRick May 2 '18 at 14:41
3

@aardvark's approach didn't work for me. However, a slightly modified version of it did work:

  1. Flag all emails that are in the Flagged folder but seemingly aren't flagged.
  2. Quit Mail using Cmd-Q.
  3. Re-open Mail, those emails should still be in the Flagged folder, but will now have the flag.
  4. Unflag them and Cmd-Q a second time.
  5. On reload, they should be correctly removed from the Flagged folder.
  • 1
    This didn't work for me. – fherzig Oct 11 '18 at 14:02
2

I frequently had this issue, a real working solution is to fully Quit mail (cmd+Q) and opening again while holding alt by clicking once the Mail icon.

  • This didn't work for me. – fherzig Oct 11 '18 at 14:02
0

I've tried all of these, to no avail. The only option was to go nuclear by deleting the offending Gmail account from Apple Mail accounts and reinstalling it. It took a few hours to reinstall all 60,000 email messages, but once it did I didn't have any more trouble with flagged messages.

You must log in to answer this question.

protected by Community Dec 7 '17 at 21:43

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .