I have a strange problem since upgrading to Lion: Some .pkg and .mpkg files won't open the installer but instead will open the terminal, and no installation takes place.
The most recent example is the Microsoft Office 2011 Update 14.1.2.

Does anyone know of that problem?

  • Ha, I thought I'll have a look if there is a new system update from Apple and – yes! – Mac OSX Update 10.7.1 solved the problem
    – treppo
    Aug 27, 2011 at 21:30
  • You should write that up as your answer.
    – daviesgeek
    Aug 27, 2011 at 22:02
  • I have the problem also mine is MBA 2011 mid. OS is 10.7.2 I cannot find installer.app in the /System/Library/CoreServices/Installer.app I am confused, can not install nothing, just I can Download from app store and save the apps.
    – user17970
    Jan 30, 2012 at 14:50

2 Answers 2


The update did not work for me, as I had already run it. It broke after the update. I still had the problem. In Finder, I could see that the file extension icon was not the gold/tan box icon that goes with Installer. There are two ways to do this. 1) In Finder, right-click, or get to the property window, and "Open With" and navigate to /System/Library/CoreServices/Installer.app. There is a checkbox to always open with this app. -or- 2) Open Installer itself and drag the mpkg file into it. Run the installer.

Both of these should run, and also change the mpkg icon in your Finder.


Ha, I thought I'll have a look if there is a new mac osx update and—"yes!"—Mac OSX Update 10.7.1 solved the problem.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .