0

Simply trying to disable Mail from downloading attachments automatically.

So I went to Mail > Preferences > Accounts > Advanced tab and turned off the "Automatically download all attachments" option. I did this for every email account on my system. I restarted Mail. It still downloads attachments from shady senders, many of which are being caught by Avira. Most of the time I right click and delete the message if it looks like junkmail, sometimes I'm quickly reading emails and forget, allowing the preview to start the attachment download. I suppose I could turn off the preview window, but I'd rather not if possible.

Any advice is appreciated. Thanks.

-1

Fixed this issue finally. I had to go to Preferences > Viewing and unchecked "Load remote content in messages."

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .