1

My 13'' MacBook Pro 2010 running Yosemite suddenly stopped booting today. After I press the power button, I can hear the chime and the computer proceed to go to a blank gray screen immediately. The screen has no apple logo or loading bar.

What I tried as of now:

  • Booting in recovery by holding CMD+R -- no effect, blank screen
  • Booting in single-user mode by holding CMD+S -- no effect, blank screen
  • Booting in verbose mode by holding CMD+V -- no effect, blank screen
  • Booting in safe mode by holding Shift -- no effect, blank screen
  • Booting in hardware diagnosis mode by holding D -- no effect, blank screen
  • Resetting PRAM by holding CMD+ALT+P+R -- reboots, chime again and then blank screen (from this I deduced that the keyboard actually works)
  • Resetting SMC by holding Shift+Alt+Control while pressing the power button, then pressing the power button alone -- no effect, blank screen
  • Choosing another booting drive or recovery partition by holding Alt -- no effect, blank screen

Is there something else I could try to get past this gray screen and try other recovery procedures?

Thanks.

EDIT: placing another hard drive in the macbook made it boot properly, so the issue doesn't lie in the rest of the hardware. Now can I recover the data on the malfunctioning drive?

  • A couple things...if you HDD died and you don't have another partition, pressing Cmd-R won't have any effect if you didn't apply the update that gives you "Internet Recovery" With no recovery medium, the MBP has nothing to boot to thus the grey screen. Do you have recovery medium? If not, do you have a friend with a Mac that can download it for you? And finally, have you tried resetting your SMC? support.apple.com/en-us/HT201295 – Allan Mar 31 '16 at 12:31
  • Hello Allan, thanks for the answer. The MacBook was up to date so I'm guessing it had Internet Recovery. I have a USB stick with a recovery partition on it, but since pressing Alt upon boot doesn't work I can't try and boot on the USB (the recovery USB does work, I tried it on another macbook with success). I'll try resetting the SMC and edit the post accordingly. – beeb Mar 31 '16 at 12:52
  • If you hold option, do any boot options appear? – Hefewe1zen Mar 31 '16 at 13:01
  • @Hefewe1zen no, like said in my original post (option = Alt). I narrowed it down to a hard drive issue, since placing another functioning hard drive in the macbook makes it book properly. Now I'll try to get the data back. – beeb Mar 31 '16 at 13:09
  • That's good to hear. But when you get a chance, try running diagnostics (D key while booting) to see if there are any issues. Also check to see what's going on with the USB. As for getting the data off the malfunctioning drive, I would get a USB 3.0 SATA adapter and run something like Disk Drill or Disk Warrior to see what you can save. – Allan Mar 31 '16 at 13:22
1

Since you are talking data recovery now, until you get all your data back DO NOT WRITE TO THE DRIVE YOU ARE RECOVERING UNDER ANY CIRCUMSTANCES, EVER, OR YOU WILL LOSE ANY AND ALL DATA ON THE DRIVE WITH ABSOLUTELY ZERO CHANCE OF RECOVERY!!!

If you really want to play it safe you should send your drive to a data recovery service. Those are expensive but you have a better chance at getting your data back. A good data recovery service can not only get data out of a drive with messed up metadata, but also a drive suffered from mild to medium damage.

The best bet without contacting a data recovery service is to boot from another device and image your drive off to another storage media. Then you can try to mount the disk image and fish your data out of it. Some Linux-based tools can be very useful.

I would suggest against using that drive ever even after you have recovered all your data. That puppy have suffered from some damage and will have a shortened lifespan. For laptops since physical movement is a daily occurrence I suggest you get an SSD for it. Not only will your laptop load faster the SSD is virtually immune to most physical trauma that can damage a hard drive so it will survive longer. By the way you can force TRIM under El Capitan so there will be no long-term speed and lifespan penalty.

  • Thanks for the advice. The damaged disk is actually an SSD, but a few years old already. I'm guessing it's dead but since I had backups I only lost a few days' worth of data. – beeb Mar 31 '16 at 14:46
  • @beeb Since you have backups you may still want to spend a Saturday fishing for information on that old drive. Maybe you can still get some back. Also upgrade to El Capitan if you can so you can take advantage of 1) a more stable kernel (Yosemite crashed a lot on me) and 2) the ability to force TRIM on without an Apple-branded SSD. Also what brand of SSD were you using? Samsung 840 Evo was notoriously problematic. I have a 3-year-old Intel SSD 520, no problem so far (but I always had TRIM on) – Maxthon Chan Mar 31 '16 at 14:51
  • Yeah I'll definitely try and get some stuff back! I'll see about upgrading to El Capitan since this old macbook already had a hard time with yosemite regarding general OS speed, maybe if I get a new SSD, but for now it's back on the original HDD. Interesting that TRIM cannot be enabled for non-apple SSDs before EC, I didn't know that. The dead drive was a Plextor PX-M5S 256GB. – beeb Apr 1 '16 at 8:20
  • @beeb Next time buy a SSD from a brand that is known for reliability. Intel, Samsung (Pro lines only,) Kingston and Micron/Crucial are all known to be very reliable. Intel SSD 535 Series 480GB, Samsung 850 Pro 500GB, Kingston SSDNow V300 480GB and Crucial B100M 512GB are all fairly reliable and balanced in price and performance. I have a 3-year-old Intel SSD 520 Series and a 1-year-old Kingston V300 240GB. Those are heavily used everyday (my daily driver MacBook Pro and my main gaming/workstation) but never failed me so far. – Maxthon Chan Apr 1 '16 at 8:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .