4

Under System Preferences > Users & Groups > Login Items, I have a number of applications that are set to launch on system startup.

Some of these, despite being marked to "Hide" on startup, insist on showing their application windows. I have to manually close them.

Edit: At first, we thought that the reason may be that some of them were also set to Open at Login in the Dock Right-Click Menu options (as speculated in the comments below) – but that can't be the reason.

For example, I've just added the mapped network drive DL below to mount on boot. Despite having checked the box Hide, the folder displays on startup.

enter image description here

  • Some applications have their own settings for visibility, which can conflict with these System Preference ones. Have you gone through their preferences to see whether such settings exist? I actually use the application's own settings as the primary one, and only very rarely go to the System Preferences tab that you're displaying there. – user158589 Mar 31 '16 at 10:07
  • @user158589 Thanks for the suggestion. The example applications I mentioned do not have a built-in option to open on startup/login. – Winterflags Mar 31 '16 at 10:10
  • 1
    @user158589 Yes, these apps are set to "Open at login" in the Dock. Perhaps I should remove that option and just keep them Hidden in the Login Items, and see what happens? – Winterflags Mar 31 '16 at 10:28
  • 2
    There you go, that's the reason why they come forward. Untick "Open at login" for every proper big dock application whose window you don't wish to see, simple as that. Many big proper dock applications have their separate background applets that will keep running even though you quit the actual application from the dock. The list of things that you see in SystemPrefs there mainly consists of those, slightly different to actual big apps. For example, just because I quit the Messages program from my dock doesn't shut down its background applet, therefore I can still get notifications from it. – user158589 Mar 31 '16 at 10:32
  • 1
    @FreeNickname Nope, haven't found a way around it. – Winterflags Oct 9 '18 at 15:02

You must log in to answer this question.

Browse other questions tagged .