2

When using Home Sharing on Apple TV 3rd gen, the Mac will fall asleep even though it is needed to stream content. So in the middle of a movie the connection will be lost because the Mac goes to sleep.

Why does it not stay awake? It seems like a big oversight on Apple's part.

1

You might want to try going to

  1. System Preferences
  2. Energy Saver
  3. Then set Display Sleep to never

If you find the need to put the display to sleep because you want to have the computer on and running for whatever reason then I would suggest going to the Screen Saver options and enabling Hot Corners. In that screen you can make the display go to sleep or trigger a screen saver by moving the mouse cursor to a corner on your screen.

Source: That is my current setup. No Display Sleep on unless I'm running a lengthy Time Machine Backup overnight.

  • I don't care if the display sleeps, I need the machine to stay awake. Having the machine never sleep is not an ideal workaround. – user166405 Mar 31 '16 at 18:22
0

There is a free app called Caffeine that adds a little coffee cup to your title bar. Click on it and the Mac will never sleep. Click again and your Mac goes back to its normal sleep pattern.

  • Thanks, but I'm more interested in why the prevention of sleep isn't triggered by default. – user166405 Mar 31 '16 at 18:25

You must log in to answer this question.