I am running the Boot Camp Assistant on El Capitan. Whenever I reach the third screen, titled "Save Windows Support Software", on which I can select an storage medium to save the Windows support software to, I am shown the following error message upon selecting a disk and hitting "Continue": "Please format the USB drive as single FAT partition.".

I am using a Transcend 16GB USB drive. I have formatted it as FAT through Disk Utility. I have tried every possible partition scheme. I have also tried formatting the drive as Ex-Fat, again in combination with all three partition schemes. I keep seeing the error message. There seem to be a fair number of people who have encountered the same issue, and for some it was resolved by formatting the drive as FAT with a MBR partition scheme. For others however this did not work.

Any advice on how to make the Boot Camp Assistant accept my USB drive would be much appreciated.

2 Answers 2


After some trial and error, I finally figured out what the problem was and found a solution. Hopefully this will help those who come across this thread with the same problem.

The problem: Reformatting using Disk Utility did not create a child partition, but only formatted the whole drive as FAT. In Disk Utility one can derive this from the "Partition" button being greyed out when the USB drive is selected. In Terminal, the diskutil list command shows the USB drive having only one DeviceNode (labelled 0).

The solution: Reformatting the USB drive using diskutil in Terminal. This is the command line equivalent of Disk Utility, but unlike its GUI Counterpart, it creates a child partition, which in turn solves the error thrown by Boot Camp Assistant.

WARNING: Proceed with caution! If you have never used a command line interface before, you might want to ask a tech-savvy friend for help. I take no responsibility for the outcome of this. If you fry your hardware in the process, that's on you. Good luck!


  1. Open the Terminal application. You can find it by searching Spotlight for "Terminal" (sans quotes).
  2. In Terminal, type diskutil list and hit enter.
  3. Look at the results and determine the identifier of your target USB drive. It will look like this: /dev/diskX. If you have only one external drive connected, this should be easy to figure out (hint: behind the identifier it says (internal, ...) or (external, ...)).
  4. Run the following command to reformat your USB drive: diskutil partitionDisk /dev/diskX 1 MBR fat32 NAME 8G. Replace /dev/diskX with the identifier of your drive which you obtained in the previous step. Replace NAME with the name you want to give the partition (which essentially doesn't matter). Make it all CAPS to avoid problems. Replace 8 in 8G with the number of Gigabytes you want your partition to have. It's easiest to just go with the total size of your USB drive.
  5. Wait for it to complete.
  6. Verify the output. The end of the command's output should show the formatting of your drive. You should see two DeviceNodes: 0, of type FDisk_partition_scheme, and 1, of type DOS_FAT_32 and with the identifier diskXs1 where X is a digit corresponding to the identifier you found in step 3.
  7. Run Boot Camp Assistant again and be happy because it finally works like a charm.
  • What was the actual cause of the problem? Was the flash drive somehow manipulated before, so that it wasn't possible to re-partition it with Disk Utility? Or is it a model-specific problem? Also, is this an El Capitan-specific problem? Commented Mar 29, 2016 at 23:44
  • @DictionaricsAnonymous I, too, had this exact problem, and I am as mystified as the OP as to why Disk Utility did not create the correct partition in the first place. I am using an 8 GB USB stick that was a giveaway at some business event, so certainly not something that was manipulated in any special way. FWIW, I'm on Mac OS X 10.11.6 on a "Late 2013" model MacBook Pro. The Boot Camp Assistant about dialog shows version 6.0.1 (6024.40.2).
    – herzbube
    Commented Oct 28, 2016 at 22:15
  • you can use R for the size to use in the partitionDisk command for rest of space instead of trying to specify the correct size
    – escrafford
    Commented Oct 6, 2019 at 20:46

To most easily resolve this, you need to erase your USB drive with a "Master Boot Record" scheme.


  1. Open Disk Utility
  2. Select the USB drive
  3. Click "Erase"
  4. Choose Format "MS-DOS (FAT)"
  5. MOST IMPORTANT: Choose Scheme "Master Boot Record"
  6. Click Erase button

Many thanks to nholtappels for figuring out the problem!

  • 1
    For High Sierra and newer, you may need to select "Show All Devices" in Disk Utility to be able to select the Master Boot Record scheme, as mentioned here.
    – davidA
    Commented Mar 11, 2020 at 6:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .