0

So I recently bought a brand new SSD for my Macbook Pro Mid 2009 Unibody. I installed the new El Capitan operating system on the SSD by using a USB-SATA cable. After it finished installing, i replaced the old harddrive with the SSD and booted the mac. However when trying to boot it gets stuck on the apple logo with progress bar underneath. It just sits there at 100% (picture below) and has done so for about 5-6 hours now.

Anybody with some sort of solution or question feel free to write I am almost willing to do anything to get it to work.

enter image description here

  • I don't understand how you "installed the new El Capitan operating system on the SSD by using a USB-SATA cable. " Did you just clone the HDD or did you do a recovery? – Allan Mar 29 '16 at 21:55
  • I think he attached the ssd to a USB case to installed the os. I'm also getting the same issue, except I cloned the HDD using superduper – yunspace Mar 30 '16 at 14:31
  • Have you tried booting in Verbose mode to see what messages are being generated? Hold Command-V while powering on. – Allan Jun 4 '16 at 11:38
1

Software causes

Possibly OS X might be booting expecting to have to work with the USB bus and getting confused by the fact it's now over SATA?

It in theory should handle that fine, but back in the day that did happen sometimes when making a clean install on a drive over USB and then moving it to SATA. Never had the problem with Cloning an existing drive since then the OS was still set up like it was on the drive that you replaced, but clean installs sometimes would get set up in such at way that when it was no longer using USB to boot it would just hang.

So if that's it, running the install afresh should fix it up.

Just checking as well, is the SSD formatted as a GUID partition table, with a Mac OS X Extended (Journaled) filesystem?

Hardware Causes

If the above doesn't fit it, but the SSD works fine over the USB to SATA connector, then it might be a problem with the Hard Drive flex cable in your Mac, or possibly (though pretty unlikely, really) the SATA controller on the Logic Board.

Were you replacing the Hard Drive just because you felt like it was a upgrade, or were you having problems with it before. If you were previously having problems, the flex cable could very likely be your culprit.

Other than that, if you accidentally disturbed the Memory modules in your Mac, it is possible it might be hanging just because of that and removing and reinstalling them could get you up and running again. Best to se if you can start the computer from your removed hard drive or the Install CDs that came with the Mac first since if either of those work ok, then it is not the Memory, and you don't really want to handle those modules if you don't have to.

More Troubleshooting

Here is a bit more information you can update your post with that can help the folks here troubleshoot with you 😊

  • SSD model
  • How you formatted the SSD
  • Was the Hard Drive working fine before replacement
  • Was the computer powered down normally (Apple Menu > Shut Down) before the SSD was disconnected after you installed it
  • Can you start the computer by holding the Command and R keys
0

Have you tried to reboot – often it helps in such situations?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .