0

When trying to upgrade to 9.3.1, the terms of service come up for the upgrade, and when clicking agree (twice -- there's two popups about agreeing), I'm redirected to the home screen and nothing else happens. Note: I had this problem with 9.3, and at the time, the 9.3 update was not signed, but as of today, IPSW says this device's update is signed and available, yet the problem remains, even after a restart.

A power cable is attached to the device (with ~80% life). I also tried closing all open applications. Still same result.

Any ideas on how to get the update installed?

4
  • I thought Apple re-released the fixed 9.3 for iPad 2? It should be available now. – fsb Mar 28 '16 at 16:40
  • @fbara Just the iPad 2, not the iPad Air 2. This is a duplicate. – Andrew Larsson Mar 28 '16 at 16:53
  • Yep this is a duplicate. I heard about the 9.3 re-release, so assumed it was fixed for ipad air 2. I see from the link on this duplicate post that (as of today, Mar 28 2016), ipad air 2's update is not signed. Thanks all! – Dolan Antenucci Mar 28 '16 at 17:41
  • After trying to install the 9.3.1 update, which is currently active/signed, I still get the same behavior, even after a restart, so I'm reopening this question. Could something be cached on my device that is causing this? – Dolan Antenucci Apr 1 '16 at 0:31
0

Installing via iTunes works (i.e., plug iPad into computer with iTunes running), so I ended up doing that.

For others that run into this problem: you may want to make sure you have enough disk space on your device. I had 32gb, so I know that wasn't my problem.

I suspect my problem had something to do with the 9.3 update arriving, and then Apple unsigning it because of its bugs; and maybe when 9.3.1 came out, my iPad was confused? shrugs

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .