I am aware there are more questions with the same title, but I couldn't find any other post with this specific case.

I have Xcode 7.0 and I want to update to the last version (7.3). But it doesn't appear in the updates page of the App Store. So, I searched for Xcode in the App Store and clicked the little update button. The button remains pressed and a loop icon appears on the top. But it stays like that for hours and there's no sign it's updating.

enter image description here

This doesn't seem to be working. I found in the internet that if I uninstall and reinstall it may work, but I don't want to lose all my projects.

  • 10
    What OS are you on? Xcode 7.3 requires El Capitan.
    – Tetsujin
    Commented Mar 28, 2016 at 14:19
  • 1
    This is still a problem 1 year and 7 months later 😞 Commented Nov 9, 2017 at 20:26
  • In case anyone is looking for 10.15, see install-xcode-on-macos-10-15-catalina on SO, and links there.
    – denis
    Commented Jan 19, 2023 at 14:56

6 Answers 6


Yes I always found updating Xcode from the App Store a painful experience.

Assuming you have an Apple ID*, you can bypass App Store and download it directly using this Apple Developer link and then find the version of Xcode you need.

As @Tetsujin says, also ensure you have an appropriate version of macOS to support the version of Xcode you are going to be running.

Note: * You no longer need a developer account, although you may want to consider this depending on the type of development you are going to be doing. See this Apple Developer page for details and links to create the appropriate account types. Note that you can start with a free Apple ID and upgrade later as necessary.

  • Those links seem to both take me back to the AppStore. Either I'm doing it wrong or something changed. Commented Nov 9, 2017 at 20:28
  • 2
    @JohannesHoff I just checked the links and both still work for me. Try copying them into a browser directly: developer.apple.com/downloads
    – Ali Beadle
    Commented Nov 10, 2017 at 14:50

This can happen with any app if you have formerly downloaded the same app (i.e. With the same internal "bundle id") from outside the App Store.

Simply move the app to the Trash, restart the App Store app and try downloading the app again.

Trashing an app does never make you lose your settings or even project. This is not Windows (where Uninstallers are common - but even those often offer an option not to delete your data) ;)

  • 1
    This solution worked for me. Small caveat: Closing the appstore with ⌘Q doesn't seem to be enough. A restart fixed it though. Commented Nov 9, 2017 at 20:29

In my case, I just had to upgrade to the latest macOS, since Xcode 7.3 requires El Capitan, just as Tetsujin pointed out.


For Xcode 11.2.1, I had to use Safari to download it from the Apple Developer website. Chrome would only download the first 1.7GB, and the update didn't appear in the App Store.

Apple Developer downloads: https://developer.apple.com/download/more/

Direct link to 11.2.1 GM: https://download.developer.apple.com/Developer_Tools/Xcode_11.2.1_GM_Seed/Xcode_11.2.1_GM_Seed.xip


Provided you have the correct MacOS updated (usually latest) do the following.

When you have app store app loaded in your mac, go to "Store" in the upper menu and then select "Reload Page". It will then show you the xcode update in the content page.


One thing I've found is that if an app is showing with a circle in the updates and not progressing is that a reboot will often fix it - had it with Xcode 12.1 which had been stuck for a week.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .