0

My wife just won an iphone 4s with iOS 9.2.1 from a friend that bought a new one.

I did a factory reset (without backup) so the phone would be completely wiped.

I turned on wifi, connected to my home network. But I can't access the Internet. Every time I try, the phone loses connection and does nothing. 3G connection works fine.

I have searched a lot and tried all major "solutions" proposed:

  • Reset phone
  • Reset Network Settings
  • Turn off Wifi-Assist
  • Turn off Wifi on location settings

And so on. Nothing I have done worked so far.

Network at home works fine. I have my android phone connected along with other devices (notebook, and iPad 2, etc).

Does anyone has any idea how to make it work? May this be a hardware problem?

EDIT

I noticed that, we can surf for quite a while and we always loose connection when opening the app store.

1

The Broadcom chip that controls the Wi-Fi connection has been known to be faulty in the iPhone 4s. I'd take it into a repair shop, as the fix requires the solder to be melted under the chip with a heat gun and it is very easy to mess it up.

You can see the details of the repair on this iFixit guide.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .