1

I really like Terminal's "Homebrew" profile (black background with green front, instead of the default white background with black font), so I set it as my default profile. This makes it so that when I initially open Terminal, the first tab that opens will use the "Homebrew" profile.

But I came across an issue where once I close the open Terminal window then try to open a new one by clicking on the terminal icon in my dock, the new Terminal window opens in the system default "Basic" profile.

Can I make Terminal open every new window with the "Homebrew" profile?

  • Why not use iTerm2? – techraf Mar 28 '16 at 6:30
1

Goto Terminal (Next to the Apple icon) -> Preferences -> Profiles

Then select HomeBrew and click "default" you can find it down there in the section you select HomeBrew.

If you like HomeBrew you might like iTerm2. Just give it a try. https://www.iterm2.com

  • iTerm2 seems like a nice permanent solution, thanks. – slightly_toasted Mar 28 '16 at 15:27
  • Glad you liked it. You can press cmd+enter to go full screen etc. just do some research. – Haneez Mar 29 '16 at 14:05
0

In Preferences->Profiles select Homebrew, and at the bottom of the list, next to the gear icon click Standard.

  • I already mentioned in my question that I set it as my default. The problem with selecting Homebrew as my default profile is that once I close the first window that opens, the next window I open will be in the Basic profile. iTerm2 seems to be a good permanent solution. – slightly_toasted Mar 28 '16 at 15:27
0

The answers above are correct. The missing bit is that you can (and should) set the default profile to use on startup to Homebrew as well.

I have added a screenshot if it helps.

Terminal -> Preferences -> General

  • As I said in my question, setting my default profile to "Homebrew" will make it so that if Terminal is not open, the first tab that opens will be in "Homebrew". But once I close that tab and click on the already open Terminal in my dock, the new tab that opens is "Basic" rather than my default "Homebrew". – slightly_toasted Mar 31 '16 at 14:08
  • Setting a default profile and setting a profile to use on startup are two different things. Did you try what I suggested? Can you take a screenshot of the General tab on Terminal Preferences for your account look like? It is certainly possible that I have failed to understand the problem. – Vishal Apr 1 '16 at 1:28
  • My settings are exactly like yours on the General tab yet the 2nd window I open is still not "Homebrew". I tried tweaking around with the settings closer to the bottom and still the same issue. iTerm seems to be a solution I can deal with, but thanks anyways. – slightly_toasted Apr 1 '16 at 4:21
0

In preferences, go to the Profiles tab. Click on the profile of your choice('Homebrew' in this case). Click on default at the bottom. This will load the same profile when you open it the second time after closing the terminal. Screenshot below.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .