I learned in Upgraded to Lion: Time Machine spends a LOT of time indexing backup that if I hold down the option key and click the Time Machine icon in the menu bar, the "Back Up Now" menu item changes to "Verify Backups". But for some reason, on my MacBook Air, "Verify Backups" is disabled (greyed-out). How do I find out why?

I'm running OS X 10.7.1, and have FileVault turned on for "Macintosh HD" (my internal storage). My Time Machine backup is to an external USB HD, which I've encrypted.

enter image description here Could that be why? Does Lion not support "Verify Backups" with an encrypted Time Machine HD?

  • Intriguing! I would presume that once you have your external drive mounted on the desktop - core storage will have the keys needed to encrypt/decrypt the volume. Can you confirm whether disk utility can verify the volume? Once that's done, can you re-check the menu for the official "verify" through Time Machine?
    – bmike
    Commented Aug 26, 2011 at 22:25
  • Disk Utility verified the volume and reported "The volume LaCie appears to be OK." But "Verify Backups" is still disabled. Commented Aug 26, 2011 at 23:00
  • Wow - I'm reaching at straws - I don't have any ideas unless you haven't made a backup lately and it knows it already just verified that backup and no changes have "happened" - really a long shot - I'll sit back and wait until I have a more solid idea...
    – bmike
    Commented Aug 26, 2011 at 23:21
  • In light of Jesse's answer below, can you please mark this "unsolved"? Clearly it has nothing to do with network vs. local storage. I will investigate the matter further.
    – user10355
    Commented Sep 15, 2011 at 2:59

3 Answers 3


Okay, so I did a bit of digging, and perhaps found a clue as to why the option is not accessible (to some at least). Read this MacWorld Hint, specifically, look down at the comment from joekewe (on Feb 08, '11 06:08:14PM):

From a web search, it looks like "Verify Time Machine Backup" should be called "Verify Time Capsule" backup. My system log shows that I attempted to verify my Time Machine backup:

com.apple.backupd[70595]: Backup verification requested by user.

but (I believe) because it is a locally mounted volume, it didn't do anything and didn't leave any more entries in the log. From this older knowledgeable article, it looks like Verify Time Machine was added when Time Capsule was having trouble.

It might be the case that he's onto something. The option is also grayed out for me, but I have a local TM disk connected via USB. Can anyone confirm they can use the feature with their Time Capsules?

It may have been that they actually fixed the menu option, in that, it should have been grayed out for Snow Leopard users connected through USB (read the comments as many people talk about having the service do nothing), but it wasn't. So in Lion, it behaves correctly.

  • 1
    cksum, perhaps you should add the specifics so readers don't have to read the Macworld hints comment: it appears "Verify Backups" only works with Time Capsules. Commented Aug 29, 2011 at 20:34
  • I'll wait a little while for confirmation from a Time Capsule owner (or for another answer) before accepting this. Commented Aug 29, 2011 at 20:35
  • I understand Daryl, but I am not in favour of paraphrasing a suspected solution. Firstly, because it's unconfirmed, but most importantly, because it is always better to go to the source. The information is there should users wish to pursue the matter (and it's not buried inside a 105 page BBB thread either—only a few comments to sort through), I was just making it available for you (and all those that may wonder about the feature). It is by no means a definite resolution to your problem. But hopefully someone sees with a Time Capsule sees this and we can get confirmation :)
    – user10355
    Commented Aug 29, 2011 at 21:18
  • I'll accept this answer, but change if if a Time Capsule owner discovers that "Verify Backups" doesn't work with it Commented Aug 31, 2011 at 22:12
  • Try running tmutil verifychecksums /Volumes/<Volume Name>
    – crazyGuy
    Commented Apr 3, 2018 at 16:37

"Verify Backups" is applicable only to backups on network drives. It will be greyed out if you are backing up to a local drive.

Apple should have been clearer in indicating this.

From Finder > Help > Verify your backup disk

Verify your backup disk

If you back up to a network disk, Time Machine periodically verifies that your backups are in good condition. If you like, you can perform a verification at any time.

  • Open the Time Machine menu in the menu bar, press the Option key on your keyboard, and then choose Verify Backups.

I have one of the new Time Capsules - 2TB, 4th generation. I used to be able to use "Verify Backups" in Snow Leopard when I had a connected USB drive and used that for Time Machine. But since switching to the Time Capsule (and the first time I've tried it in Lion), "Verify Backups" is greyed out :(

Update: Strange! Now it's working. I just tried it with my Time Capsule and its verifying. It got further than it did last time. It's at 11% (and much slower I will say vs. when in Snow Leopard) currently. But its working. So it appears that the greyed out menubar was a bug? Not sure when it decided to not be greyed out anymore.

  • Look at my update to the post.. Commented Sep 18, 2011 at 13:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .