1

Been running El Capitan since it was officially released. Updated to 10.11.4 a few days ago. I have a WD Elements USB 3.0 drive connected to my Mac mini (directly to the rear ports, not via a hub). Ever since the update to 10.11.4 whenever my Mac goes to sleep and I wake it up again, I get a notification to say the "Disk was not ejected properly".

This has never happened with this drive before, not on Mountain Lion, Mavericks, Yosemite or El Capitan until now.

I have another external caddy also with a full size 3.5" drive in it. This is powered by the mains.

It seems to me that the Mac is now terminating power to the USB 3.0 port prematurely (before the disk has had a chance to unmount properly ?), I do not get the message for my full-size disk that is permanently powered.

Tried adding the disk to the spotlight ignore list but to no avail.

Anyone else notices this issue?

  • 1
    Same here... Did not have this problem before until I upgraded to 10.11.4 on my 2015 15" MBP attached to my TimeMachine drive (USB3 WD 1TB MyPassport drive). – Scott Mar 29 '16 at 20:18
  • Similar: External hard disc not ejected properly – kenorb Feb 22 '18 at 15:03
2

I have the same problem with my LaCie 6TB drive which is used by Time Machine and is USB 3 connected. The problem only started after upgrading to 10.11.4. I don't have the problem with my 10.11.4 MBP using Wi-Fi to backup to my 3TB Time Capsule. I have reported the problem to Apple and await a solution.

1

Solved this issue on late 2013 iMac 27 running Sienna-system preferences-energy saver-first box checked (prevent a computer from sleeping automatically when the display is off) and all others unchecked. Turn display off after-never.

Now I do not get the problem from external drives in USB hub of the disk not ejected properly.

0

Updating to 10.11.5 seems to have fixed this for me now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .