1

Tried to install Xcode for the first time. Tried 3 times now, same problem each time. After it reaches around 95% it fails, and I have to restart from scratch (2.5h). Going crazy.

Could it be because the computer goes into "rest-mode" while it installs?, i.e., black screen. Don't see what else it could be. Internet is fine, and I get no info apart from "Failed to install Xcode".

1

I had the same problem and I fixed it following the instructions of the first answer to a similar question: https://apple.stackexchange.com/a/97910/135650
You need to enable the debug menu for the App Store app and reset the application:

  1. Open the terminal
  2. Run the following command:
    defaults write com.apple.appstore ShowDebugMenu -bool true
  3. Relaunch the App Store app.
  4. Choose the menu item Debug → Reset Application.

If you follow this instructions and still get any error I recommend you to check if you has at least 10GB of free space on disk before try again.

Optionally, you can always download manually this or any other update from the following link:

(you need to enter your Apple ID in order to be able to download)

https://developer.apple.com/downloads/

or even better with this directly link(Xcode version 7.3):

https://developer.apple.com/services-account/download?path=/Developer_Tools/Xcode_7.3/Xcode_7.3.dmg

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .