2

I am having trouble with Wake On Lan for my Mac. I am trying to wake it over the internet from my phone so I can log in to TeamViewer and control it remotely. I don't know if it is my router that is the issue or something on the Mac. Here is my setup:

  • OS: Yosemite 10.10.3
  • Machine: MacBook Pro (Retina, Mid 2012)
  • Router: Xfinity Arris TG1682G, forwarding Ports 7, 9, 22 over UDP to my static IP machine
  • Apple TV: 4th Gen

I can SSH into my Mac on my phone from the outside (i.e. on it's LTE connection) while the Mac is turned on. I've been trying for hours to figure out how to wake it first when it is off. I have turned on Back to My Mac and tried to use the remote login and screen sharing features but nothing works.

I thought having an Apple TV on the network would help wake up the Mac, but no. I also have the option turned on to Wake for Wi-fi Network Access in Energy Saver settings. I have tried using some WOL iOS apps like Mocha WOL and SimpleWol, sending to both port 7 and 9. I still can't wake it to SSH into from my phone. My laptop is open and and not clamped shut.

I can't for the life of me get this working, any help is much appreciated :)

EDIT: It is connected via WiFi if that makes any difference, though I believe it shouldn't

  • 2
    You'll need to make sure your MacBook is plugged in and powered for WOL to work. That one gets me every time. Otherwise, the rest of your setup looks okay, and I'd be surprised if it didn't work. – perhapsmaybeharry Mar 26 '16 at 10:20
  • Thanks but I was already doing this... I have no idea what's wrong, if you have any other suggestions that'd be great – milkyway Mar 26 '16 at 15:49
  • @perhapsmaybeharry I think that my Mac is having trouble registering to the Bonjour Sleep Proxy on my Apple TV. Either this or my router is blocking the packet being sent. How Are you using an Apple TV? How is your setup working? – milkyway Mar 29 '16 at 0:52
  • I don't actually use an Apple TV, but I'll see what I can dig up around the internet related to your matter. – perhapsmaybeharry Mar 29 '16 at 3:09
  • tonymacx86.com/threads/… I found this site and it suggest changing a plist file: went to /Library/Preferences/SystemConfiguration/com.apple.PowerManagement.plist and changed "PrioritizeNetworkReachabilityOverSleep" from a "0" to a "1" – John Pang Sep 6 '16 at 4:42

You must log in to answer this question.

Browse other questions tagged .