I've just upgraded to El Capitan from Mountain Lion, and now an Other... icon appears right next to my usual user-account (admin account) on the login screen. When I click on it, I can log in, as another user, but I only have one.

My first thought was, that it could be the root user, which could have been enabled (I don't know how though). But from the Edit menu, in the Directory Utility, it only says "Enable root user", which should indicate that the root user is disabled. I then tried to enable it, and disable it again, but the Other... still appears on the login screen.

I've even tried to disable it from Terminal using this command, with no luck:

dsenableroot -d

After some search on Google, I found a thread with people having the same problem. A lot of them solved the problem by following this guide:

  1. Enable the root user from Directory Utility and then log out.
  2. Log in as the root user account and change the password.
  3. Still on the root user account, disable and then enable root user from Directory Utility.
  4. Log out from the root user account, and log back it to the usual account.
  5. Now disable the root user once again.

I have done all this, but it still doesn't work, and I am almost going mad about it.

Anyone have any idea why this is happening, and how to fix it?

3 Answers 3


I finally found a solution!

After some more search I found this command:

sudo defaults write /Library/Preferences/com.apple.loginwindow SHOWOTHERUSERS_MANAGED -bool FALSE

..and it did the trick!

  • This also works for macOS Sierra. I suddenly had this rogue "other" user appearing on my login screen and couldn't find any tips how to get rid of it. Nice find and thanks for sharing!
    – DrZoo
    Aug 12, 2017 at 2:58
  • This command also works for macOS 10.13 "High Sierra".
    – rjb
    Sep 28, 2017 at 16:58
  • Thank you, sir, it still works (macOS Mojave).
    – Andrew G
    Jun 8, 2019 at 16:43
  • This command also works for macOS Catalina. Thank you!
    – bitdancer
    Oct 18, 2019 at 15:23
  • And works for macOS Big Sur.
    – GutenYe
    Nov 26, 2020 at 11:40

It can be changed by using Terminal command:

sudo defaults write /Library/Preferences/com.apple.loginwindow SHOWOTHERUSERS_MANAGED -bool FALSE

One can also revert back:

sudo defaults write /Library/Preferences/com.apple.loginwindow SHOWOTHERUSERS_MANAGED -bool TRUE

I solved this a different way, a better way in my opinion, in my case the root user was active so I turned it off following Apple's instructions.

Just in case the above link stops working, these are the steps:

  • System Preferences
  • Users & Groups
  • Unlock (bottom left)
  • Login Options
  • Join
  • Open Directory Utility
  • in Directory Utility Unlock (bottom left)
  • In Edit Menu, select Disable Root User

Note: I don't know why the root user was active. It might have something to do with the Guest User or with Find My Mac.

  • My edit menu only showed 'Enable Root User'. The accepted answer did the trick for me.
    – GoZoner
    Oct 14, 2019 at 16:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .