1

So my bluetooth keyboard function key hasn't been working for a while, the built in one works fine. I bought a new apple keyboard to try and fix the problem but turns out its my laptop. I also noticed that where the bluetooth settings used to show battery levels for apple products, it no longer does.

All the F1-12 keys work fine but the function key its self doesn't work at all or in combination with other keys.

In the bluetooth settings it says no battery but at the time the keyboard batteries were full.

I have tried basic things like un-pairing and pairing again, also some commands to unload and load bluetooth files.

Thanks.

[xx] [yy] [zz]

1

What is the model and age of your laptop?

I had some trackpad issues a month or so ago with my own Macbook, and it turned out that the battery was in need of replacement, swelling and pressing the trackpad. Also, have you tried clearing the NVRAM? Press the built-in keyboard keys P R option command while rebooting to clear the NVRAM. Also it might be worthwhile to clear the system caches … hold down the shift key while rebooting to do that. Then try re-pairing the bluetooth device and see if it is any more successful.

  • Its a late 2013 Macbook Pro, i have tried the NVRAM but will try the caches. – Jleagle Mar 25 '16 at 12:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .