1

I have an MBP latest OS running, I tried to follow a guide to install VirtualEnvWrapper a few weeks ago, not too sure why.

But I keep getting this error when opening terminal and its quite annoying, how to get rid? http://puu.sh/nSu82/fcb2f5291a.png

and in my sublime text I see it too: http://puu.sh/nSu9F/2cc43f46a0.png

How can I fix this?

Edit: I also tried sed -n '3p' $HOME/.bash_profile

and got

source /usr/local/bin/virtualenvwrapper_lazy.sh

  • It looks like you need to remove line 3 of your .bash_profile which contains a reference to /usr/local/bin/virtualenvwrapper_lazy.sh. Edit your post with the results of this command sed -n '3p' $HOME/.bash_profile – fd0 Mar 24 '16 at 19:01
  • what do you mean by edit my post. I typed in what you stated and I received this in response: sed -n '3p' $HOME/.bash_profile source /usr/local/bin/virtualenvwrapper_lazy.sh – ebaydan777 Mar 24 '16 at 19:26
  • I now have a screen image of .bash_profile itself: puu.sh/nSwNN/40d3031c44.png – ebaydan777 Mar 24 '16 at 19:29
  • Remove the offending line and the error message will go away. Then try to reinstall VirtualEnv following the guide (if you really need it). – nohillside Mar 24 '16 at 21:01

You must log in to answer this question.

Browse other questions tagged .