4

I am attending a meeting in a quiet room where everyone has a soft voice, and my mac decides to index for spotlight (the job is 'mds'), bringing the fan to 6200rpm. It's not too bad, just a bit distracting.

How do I tell mds that this is not the right time to do its job? Killing it to delay it could mean that it would choose to start a minute later.

Please note that this is not a case of initial indexing. I don't know (and I don't really care) why mds has a tendency to spend a lot of time not only after inserting a USB flash drive that the machine has not seen in a while, but also after removing that flash drive.

  • Welcome to the community. You are asking two separate questions here. Please take your secondary question and post it as a new one. Thanks – Philip Regan Aug 26 '11 at 14:43
  • All right.. I reworded the question. – Calaf Aug 26 '11 at 14:52
5

To turn off Spotlight indexing for all mounted volumes:

sudo mdutil -a -i off

See the mdutil man page for other options.

  • 2
    ...and that doesn't abort ongoing mds tasks, but lets them finish gracefully -- nice. Thanks. – Calaf Sep 3 '11 at 2:23
  • Will the process restart once I plug in my laptop power or restart the laptop? – Enrico Susatyo Feb 12 '14 at 11:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .