6

I often need to write emails in French that contain English technical words and it seems that the spell check in OSX can't understand that a document can contain both languages.

The result is either French or English words are red-underlined and this isn't pretty.

I've tried the trick on How to make Firefox to spellcheck in multiple languages simultaneously? that consists in merging several .dic and .aff files downloaded from titoBouzout/Dictionaries but the grammar check is less precise than the default OSX one.

2

Go to system preferences/keyboard/text/spelling and click on the window and go to the Setup item. Then check the boxes for only the two languages you want and set it to Automatic. Also set the dictionary to Automatic in Edit > Spelling and Grammar > Show Spelling and Grammar.

I suspect this works better for separate sentences or paragraphs in different languages than for different languages in one sentence.

  • On Mojave at least it seems to not honour that list if you set it to automatic. For instance I want German and British English. But even though the list has only those languages (and more importantly does NOT have American English) when I spell a word the American way it sees it valid. Which rather makes it useless for me. But it does however work in the same sentence even. Either way it seems to not honour the list of languages enabled when in 'auto'. Unfortunately that's the only way I know to 'remove' the dictionary of the spellings I do not want. – Pryftan Jul 21 at 17:32
  • Actually it seems to be a bug: the list of languages says this: '...and select those that should be used when spelling is being checked automatically by language'. – Pryftan Jul 21 at 17:36
1

Try this:

  1. Go into System Preferences / Language and Region and set French as Primary language under Preferred languages.
  2. Restart the computer.
  3. Set back you previous primary language (by dragging it from the Preferred languages list to the top).
  4. Restart.

I just tried this, and even after deleting French from my Preferred languages it kept correctly correcting French words.

I'm not entirely sure why, but it seem to do the trick.

1

Tom Gewecke's solution mostly worked for me, but I had to add a secondary source in Keyboard -> Input sources. Then it worked as expected.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .