0

Recently I downloaded VirtualBox to setup a Windows 10 Virtual Machine on my Macbook Pro. I bought a new 32gb PNY flash drive to boot Windows 10. Everything worked great until I shut everything down. Now my Mac doesn't recognize the flash drive (even disk utility gives me nothing). My USB ports are both fine and the flash drive still works with Windows machines. My question is two-fold, can I fix this and more importantly, can I prevent it from happening again?

  • Just to clarify....did you use the USB drive to hold the .vdi file - meaning you boot your VM from a virtual disk on the USB or the USB is the virtual disk. I had a similar issue to what klanomath is describing below, but I don't think it applies. apple.stackexchange.com/questions/183003/… but I just want to confirm – Allan Mar 22 '16 at 0:30
  • That's exactly what I did – ace7 Mar 22 '16 at 16:00
  • @ace7 Please don't answer an "or" question with "That's exactly what I did! – klanomath Mar 22 '16 at 16:14
  • Which one of the two scenarios did you exactly do? – Allan Mar 22 '16 at 18:42
  • Here's what I can recall, forgive me if my vocabulary isn't perfect.I used my USB drive to download the windows.iso file. I plugged my usb into my mac and used that to boot my VM. I avoided any customization options, and went with all the defaults that VM and Windwos 10 presented to me. Everything worked fine, my VM worked. I shut the VM down, ejected the flash drive and went to bed. That was the last time my Mac could recognize the flash drive. The USB ports, the flashdrive, and Virtual Box all work fine but my mac cannot, in any way that has been presented to me, recognize my USB drive – ace7 Mar 23 '16 at 13:58
1

You probably enabled a USB device filter in the VM and added the PNY flash drive. After configuring it like this the USB device is invisible for the host (also in Disk Utility). Choose the USB device in the VM settings -> Ports -> USB, hit the red minus-button and quit VirtualBox and the PNY will reappear.

enter image description here

  • No dice. The virtual machine didn't recognize the flash drive either – ace7 Mar 22 '16 at 16:04
  • @ace7 Please extend your question and add your config. I understood your question as following: you created a Windows installer USB thumb drive and installed the VM to your internal MacBook disk. Apparently that's not the case. Did you save the virtual disk to the PNY or is the PNY a raw disk containing the installed Windows? – klanomath Mar 22 '16 at 16:12
  • The PNY is a raw disk containing a windows .iso file. Do you want my macbook config or the virtual machine? – ace7 Mar 22 '16 at 16:56
  • @ace7 Raw disk has a special meaning in VirtualBox. You can "map" a real volume (e.g /dev/disk1s2) to a vdi file. Writing to the vdi doesn't increase the size of the vdi file in the VM folder but writes directly to the "mapped" real volume (=raw disk mode)! – klanomath Mar 22 '16 at 17:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .