At a public WiFi where I have not had this issue before (but last time was two months ago). WiFi connection symptoms seem like the access point/router is not communicating with the outside world. BUT it is a little unusual:

  1. Macbook, iPad, and iPhone all connect to the SSID. But none of them can access internet at one end of the building and the iPad works fine at the other end. Nowhere in the building can the Mac even ping the router.
  2. Typing this on a library Windows 7 box. I shut this box and the Macbook down, and moved the Cat-5 cable from their box to the Macbook. Booted and tried different methods (ping/telnet to DNS/whois/others) and no connection.
  3. Sounds like Macbook is seriously screwed, but I can use the iPhone "personal hotspot" through USB or through WiFi with the only issue being that the cell service around here is intermittent.

Any troubleshooting ideas? Is this a duplicate of Network OK but no Internet connection. Can this be faulty hardware? ?

Update: "Related" sidebar shows that many people have similar problems, though none of those showed up in the "suggestions" when I was typing the question.

  • I think you could drop the word library altogether from the question. In a computer-oriented QA forum it's highly confusing. The building's purpose is irrelevant to the question – Tetsujin Mar 21 '16 at 17:19
  • Most of this post could be edited out and replaced with the results of running "Network Diagnostics" to pinpoint the first failure the Mac sees in setting up a network connection to the internet. See apple.stackexchange.com/a/230023/5472 – bmike Mar 21 '16 at 17:32
  • If I have time before leaving again (only ten days for a long to-do list, not helped by bad cell coverage) I might try that. But last time I ran Network Diagnostics, it generated a huge amount of stuff, none of which seemed useful to me (and I've just retired from thirty years as a software professional, with ten years of electronics before that). I am now at my sister's house, having NO problems with her WiFi. – WGroleau Mar 21 '16 at 20:07
  • @WGroleau Can you rule out any MAC filter on the router/access point (or other tools like a Network Policy Server (Windows Server)) and/or a wrong IP configuration of the MacBook? – klanomath Mar 21 '16 at 20:17
  • Can't rule out a MAC filter (and librarians don't know) but it is highly unlikely, as this is public access--blocking only me would require them to find my MAC address in logs from two months ago and block me specifically. Net Policy, could be, but why would it block a Macbook and not my other devices and those of other visitors? IP config--unlikely, as it works in most places, and I have experience doing that. Also, I intentionally tried changes to that without helping the problem. – WGroleau Mar 21 '16 at 20:26

You must log in to answer this question.

Browse other questions tagged .