3

Revised question

As per Tetsujin's suggestion in the comments I did some further testing.

There seems to be a problem with iCloud and sending a zip file of a folder with a certain amount of files. There appears to be a limit of 127 files in 1 folder, regardless of file type (tried .png, .svg and .txt).

When sending the mail using the Mail app I get a message size violation error and the mail can not be sent. Using the iCloud web interface the mail does appear to be sent (no error, appears in 'sent' list) but it never arrives.

Does anyone know why this limit exists? (as Tetsujin mentioned in the comments it might be some 7-bit shenanigans)


Old question

If I try to send an email with a 1.3 MB zip file as attachment I get a message size violation error:

Mail error

File sizes of the zip file and original folder (1.3 MB and 10.7 MB respectively):

Info panel zip file and folder

At first I thought it was somehow related the original folder being more than 10 MB, but according to Apple's iCloud support page the limit is 20 MB:

Limits on sending messages

There are several safeguards in place to make sure that only iCloud members can send messages using iCloud. One of these safeguards includes reasonable limits on:

  • ...
  • The size of incoming and outgoing messages (20 MB, up to 5 GB with Mail Drop turned on)

Why am I unable to send this zip file? (also: shouldn't Mail Drop kick in if it thinks the attachment is too large? It is turned on.)

  • I'd first just suspect 'glitch'. Try a new mail with the same attachment, & a new mail with a re-zipped version. That will eliminate a couple of options. – Tetsujin Mar 21 '16 at 10:00
  • Sending a new mail, using a different iCloud address, restarting Mail nor rezipping the folder worked unfortunately. – Kymer Mar 21 '16 at 10:08
  • Does it send if there's no attachment at all, or a different attachment entirely? – Tetsujin Mar 21 '16 at 10:11
  • 1
    Okay I did some testing: the problem seems to be the number of files in 1 folder. The limit is 127 files in a zipped folder. The moment I add 1 more file the zip doesn't send. (regardless of file type, I tested using PNG's SVG's and TXT files) – Kymer Mar 21 '16 at 10:38
  • 1
    It's a prime example of some kind of 7-bit addressing system, though why it should be so limited in this day & age is anyone's guess – Tetsujin Mar 21 '16 at 11:02
2

I just ran into the same problem : zipped two 11.5 MB Xojo compiled apps. Sending from me.com or sending to me.com gave the 'message size violation' error.

To bypass this possible 127-file limit, I created an empty disk image with Disk Utility. Mounted it and copied the two apps onto it. Unmounted and zipped it and sent it via me.com : that worked.

  • I created a tar archive of my zip file and that also worked. From the terminal - tar - cf outputfile.tar inputfile.zip – Jackson Dec 8 '18 at 20:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .