1

My WD 2 TB hard drive has suddenly stopped being recognized by my MacBook Pro, running OS X 10.11.3, but it's working on my ThinkPad, running Windows 7 and Linux Mint. The solution I found was to reformat the drive. However, I cannot do that as I do not have a place to copy all the files on the HD to.

I've had a similar issue before in Windows 7. I went to some part of the Registry and deleted the records pertaining to the USB drive and it worked fine after that.

Is there any similar solution like that in OS X?

The output for 'diskutil list':

$ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *251.0 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage Macintosh HD            250.1 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
/dev/disk1 (internal, virtual):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS Macintosh HD           +249.8 GB   disk1
                                 Logical Volume on disk0s2
                                 3D4D9C68-75DA-41A9-BCF7-54D66F542074
                                 Unencrypted
/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *2.0 TB     disk2
   1:               Windows_NTFS Elements                2.0 TB     disk2s1

Screenshot of "Get Info": Get info of USB drive

8
  • Can you post the information provided by diskutil list from the Terminal (found at /Applications/Utilities/Terminal.app)? This should list the disks that your system registers. Mar 21, 2016 at 4:56
  • Now it being recognised but I am unable to copy files into it. In Get info, Sharing & Permissions: You can only read.
    – qbektrix
    Mar 21, 2016 at 16:15
  • @perhapsmaybeharry As I have crossed the word limit for the sharing the output, I have edited it to the message.
    – qbektrix
    Mar 21, 2016 at 16:19
  • unrelated question: How do I format my terminal output?
    – qbektrix
    Mar 21, 2016 at 16:28
  • @qbektrix to get a box like visible now, prepend 4 x space on every new line
    – klanomath
    Mar 21, 2016 at 16:39

1 Answer 1

1

Have a look here on to enable native write support to NTFS.

4
  • I checked my username by using "whoami". Then using that I ran the command. What followed was a list of outputs like: chown: <folder and file path>: Read-only file system ending with... chown: /Volumes/Elements/: Read-only file system Problem still persist.
    – qbektrix
    Mar 26, 2016 at 3:25
  • Oh wait, it's NTFS. NTFS isn't exactly directly editable by OS X... Mar 26, 2016 at 3:27
  • Do I have any option?
    – qbektrix
    Mar 26, 2016 at 3:28
  • Yep, edited my answer to reflect this. Mar 26, 2016 at 3:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .