I'm aware of this question, however it doesn't solve my problem.

Today I bought a water damaged iPhone 6 at a good price, thinking that since I am pretty decent at repairing iPhones (and fixing water damaged ones before), that I should be able to fix it without any issues and have a working iPhone 6. However, after doing my usual "take the while thing apart and clean it with isopropyl alcohol" water damage repair routine that has worked well in the past, it still won't turn on or even be recognized by iTunes.

This iPhone 6 has been dropped in a pool, whether it's chlorinated or saltwater, I don't know. I do know that it has been around a week since then, the seller informed me.

I have tried (in order):

  1. Cleaning with an alcohol-soaked cloth multiple times
  2. Taking a spudger and gently scraping around the chips
  3. Soaking the board in alcohol and when that didn't work, cleaning it with a toothbrush while submerged in alcohol
  4. Running the logic board under warm tap water, then submerging it in alcohol and cleaning with a toothbrush again

In each case, I made sure that the board was dry before testing.

Edit: I decided to break out the soldering iron and removed all three shields from the logic board. After removing the first one (the one below the SIM slot), the iPhone came on, but was stuck in a boot loop. However, after removing the second one (on the back), the phone no longer comes on, and cleaning the behind the third one (covering the A8) didn't help either. Strangely, sometimes when I connect the iPhone to the wall charger, if I press the shield up where it should go, the Apple logo flashes once and then goes to black, though the LCD is on. Any ideas on what to do next? Can I use computer thermal paste on the A8 chip and heat sink; is it the same thing as what's already on it?

Any ideas on how to fix the board?

Also, it's almost definitely the board, as I've used multiple lightning docks and digitizer assemblies for the iPhone 6 that I had lying around and bypassed the battery by plugging the iPhone straight into the wall.


1 Answer 1


Perhaps the battery is dead and the U2 IC chip (controls battery charging) is also dead?

There is a way to bypass the U2 IC (though potentially very dangerous, but it sounds like you might know what you are doing).


Ive also seen a youtube video where the battery was disconnected from the phone and charged directly... but i can't find it at the moment...

  • Comments are not for extended discussion; this conversation has been moved to chat.
    – bmike
    Mar 22, 2016 at 16:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .