I have a bizarre problem with my 2012 MacBook Air 13":

At some point, a couple of weeks ago, it suddenly stopped turning on. The battery would charge, but pressing the power-button just wouldn't have an effect. I clearing the SMC by pressing Shift-Control-Option, which didn't have any effect. I tried different power adapters.

Then in a last-ditch effort I decided to open it up. Much to my surprise it did boot up just fine after: disconnecting the battery, pressing the power button (with AC not attached), reconnecting the battery, reconnecting AC power, and pressing power.

The weird thing is that everything (including the power button, going to sleep etc) just works, just when I shut down OS X completely, the same problem occurs (all the times), making it necessary to unscrew the bottom and do aforementioned procedure again ;)

Have anyone heard of this problem before? Are there some specific components on the logic board that could be causing this? (I am not sure if it's worth having this repaired through official channels.)

Update: To clarify the symptoms when the Air doesn't boot up: black screen, no fan, no keyboard backlight (or anything else that would indicate that it is running).

  • Start SystemInformation (in Applications/Utilities), select "Power" in the left Navigation Panel: what does it say on the right under "BatteryInformation:->Health Information:" ?
    – LexS
    Commented Dec 6, 2016 at 17:31
  • Since I'm having the same issue, and the OP didn't answer you, I will, @LexS: imgur.com/a/eAw47PZ Commented Mar 20, 2019 at 10:40

1 Answer 1


There are two possible causes these symptoms:

  • Faulty Battery

  • Bad SMC Chip (Logic Board)

Faulty Battery. As the OP described, once the battery was disconnected, the machine booted fine. What could be happening here is that the battery life has degraded to the point where it will not hold a charge above the threshold to power on the device.

If you can power the MBA in this manner, try resetting the SMC then reconnect the battery. If it continues to fail, you probably need a new battery. If you already know how to open the MBA and disconnect the battery, you are halfway to replacing it. If you're not sure, ifixit.com has an excellent tutorial.

Given that the OP's machine is a 2012, it would mean the battery is pushing 5 years now which is around the EOL for this battery. It's time for a replacement. I recommend getting one with at least a 18 month warranty.

Faulty SMC. There is a possibility that the SMC (chip) is faulty. The first thing to attempt to diagnose it would be to run Apple Hardware Test (AHT). Hold the D key while booting from a powered off state with the AC adapter connected.

It may come back with "no errors" so the positive diagnostic test would be to attempt with a known "good" battery. If it continues to fail after the battery is replaced, there's a high chance than the SMC is bad. It's time to take it in for service.

  • I'm having the same issue, and don't think it fits the 1st cause. The battery does charge and hold power; the problem only arises when the computer is fully shut down. Restart works, sleep works, powering from the battery works… it's really only when it's shut down. Then, as described in the OP, I need to open it, disconnect the battery and power it on normally. Then I can reconnect the battery (with the charger connected, of course). I ran the AHT, upon your recommendation, and it indeed said the battery is not functioning properly. But… it's charging and powering the computer normally. Why? Commented Mar 20, 2019 at 10:36
  • Exact same issue, computer refuses to start from a powered off state if the battery is plugged in. Replacing with a third-party battery did not improve this. Any further tests would be appreciated. Commented Apr 14, 2020 at 7:27
  • 1
    There’s really no more tests that a user can do, @LouisGarczynski. Apple would replace the logic board, but a company that specializes in this would break out the diagnostic gear and figure out what component(s) on the board are bad and replace them. It’s time to take it in for service
    – Allan
    Commented Apr 14, 2020 at 14:03
  • I am also seeing the same issue with my Macbook Air Mid 2013. However in my case it appears the power button itself is faulty. If I disconnect the battery and power adapter and connect the power adapter, it basically powers on itself without pressing any button. Also, when the device is powered on, pressing and holding the power button does not turn the device off. Commented Oct 5, 2021 at 17:27
  • So it appears this issue can also happen if the power button on the keyboard is dead. Also, shorting the power pads on the logic board also powers on the device. Commented Oct 5, 2021 at 17:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .