1

TL;DR: I have an external USB wifi adapter on a MacBook Pro which was working fine before I deleted my /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist file without making a copy. Is there a way of fixing it?

The problem with my MacBook Pro 2014 started when it took a water damage. The only ostensible casualty was the wifi function, and apple told me it was caused by the breaking down of the wifi airport card. There is apparently other hardware damage, but no other symptom that I can see. But to fix the whole thing will cost almost as much as a new machine, so I decided to buy a USB adapter (http://www.tp-link.com/en/products/details/cat-11_Archer-T4U.html) to regain the wifi function.

The external adapter was working fine for a week, the only problem being that I cannot log in to the appstore, with the error message "An unexpected error occurred while signing in, Your device or computer could not be verified". So I followed the advice here and deleted /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist. Stupidly, I did not make a copy. After a reboot, the status bar looks perfectly fine, and shows me connected to the network (itself fine, too), but there's just no connection to the Internet. I've tried restoring the preference file from a month ago and re-installing the usb adapter driver, but no improvement. I am eliciting your help for any ways to fix this, or any suggestions of what to try.

0

System Preferences > Network

If you can see your USB adapter in the list unplug it, Delete the entry using the "-" button bottom left of list of devices.

Then plug it back in, if it fails to auto detect then press the "+" button and add your USB adapter.

If it doesn't show your adapter in the list: then press the "+" button and add your USB adapter.

Only do this if the option above don't work, it could be the permissions have gone awry on the directory to NetworkInterfaces.plist , in which case use disk utility to repair permissions on your hard drive, select the Volume such as "Macintosh HD" not the physical drive when you do this. If you are on El Capitan you will need run from teh Terminal

csrutil status

If System Integrity Protection is enabled (which it should be in most cases), then the command output will indicate so. Being enabled will in turn indicate that permissions have been checked and maintained.

  • Wow, wow, wow. I just deleted the entry in the network interface and the readded it. It worked perfectly. Thank you so much for helping out. – Yang Mar 19 '16 at 0:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .