14

I know this has been asked here several times, but I already checked the other discussions and tried their suggestions, but without success. Is there anything I can do instead of re-installing the complete system?

When certain applications want to access the keychain, I am getting asked for the "login" keychain password repeatedly and never-ending, even though I type in the correct password.

I already tried the following, separate from each other:

  • Keychain Access > Preferences > Reset my default key chain
  • reset the password (new password = old password) of the login keychain
  • Deleting the ~/Library/Keychains/XYZ... folder (as suggested here: https://apple.stackexchange.com/a/148437/5924)
  • restarted several times

Now I wanted to simply grant access to all applications to certain keychains, but when wanting to save the changes, I have the same as the original issue: I get asked for the login keychain password, which never gets accepted. I am definitely typing the correct password, I can even lock and unlock the keychain with it without problems. Or even reset the password. It just won't help. (And in case it matters: the "login" keychain password is the same that I use for my user account.)

Here is the screencast video: https://www.dropbox.com/home/Public?preview=video3.m4v

[enter image description here]

(I'm on El Capitan, the Keychain Access is Version 9.0 (55171.20.2))

Related discussions, but none of them helped:

===UPDATE===

I just came across this thread: Keychain does not show passwords after El Capitan upgrade

and indeed, this is also the message I am getting in the /var/log/system.log:

SecurityAgent[877]: Ignoring user action since the dialog has received events from an untrusted source 

but I am already using a real mouse (Magic Mouse) and/or the built-in touchpad of my Mac, so the proposed solution there does not help much:

So a solution to this problem is to use a physical mouse to interact with the Keychain.

(By the way: I have all recent updates installed that I got auto-notified about via App Store.)

What's also interesting, looking at the system.log: it shows a lot of these lines quite frequentely, without any user interaction and every few seconds:

secd[292]:  __SOSCCProcessSyncWithAllPeers_Server_block_invoke sync with all peers failed: Error Domain=com.apple.security.sos.error Code=1032 "peer: UQl/Oz6WIs//dOl3o8fSLDAa2p not found" UserInfo={NSDescription=peer: UQl/Oz6WIs//dOl3o8fSLDAa2p not found}
Mar 21 22:40:04 mln-mbp CloudKeychainProxy[344]:  __39-[UbiqitousKVSProxy doSyncWithAllPeers]_block_invoke_2 <UB--s--C---> syncWithAllPeers (null), rescheduling timer

(Now I just removed the keychain from being stored on iCloud and the error in the log stopped.)

  • Have you already tried ye ole Repair Permissions routine (Disk Utility's First Aid) and the repair home folder permissions (from the Recovery Partition system)? – Dictionarics Anonymous Mar 17 '16 at 17:50
  • @DictionaricsAnonymous I just ran a First Aid, and I got some errors. Even though the First Aid dialog says "It will then repair the volume if necessary.", the volume still shows the errors if I ran First Aid for again. snag.gy/A9JAJ.jpg About permission repair of home folder: how to access that / I don't seem to have a recovery partition, when looking into the partitions (see screenshot). Would the partition not appear there as well? Is the DiskUtility that I can access via boot & cmd+R different than the DiskUtility I ran First Aid from? (Doing a TimeMachine backup before next steps) – Mathias Conradt Mar 17 '16 at 18:45
  • Nevermind about the partition, I see it via "diskutil list" - pastebin.com/XfBViF3B and a forum discussion on El Capitan discussions.apple.com/thread/7254480?tstart=0 – Mathias Conradt Mar 17 '16 at 18:50
  • Ah, I don't have El Capitan and didn't know it brought some changes … If not everything has changed, you need to boot to the Recovery system (restart +hold down Cmd-R), then launch Disk Utility and let it repair 'Macintosh HD' from there. It should fix that file system corruption. If not, run it again. But my original idea was to repair PERMISSIONS, and this feature was removed from Disk Utility in El Capitan. I suggest you fix that corruption first, then attempt to repair the two permission systems. I'll have to google around to see if that even still applies to El Capitan... – Dictionarics Anonymous Mar 17 '16 at 20:43
  • 2
    To reset the home folder folder permissions, boot into the Recovery system, launch the Terminal application (Utilities menu) and type in the command resetpassword (in one word). A separate application will launch, in which you select 'Macintosh HD' and then your user name, then click 'Reset' at the bottom of the window. – Dictionarics Anonymous Mar 18 '16 at 13:42
7

I had exactly the same problem with Lync messenger - request to enter a keychain password, over and over again, even though password was the correct one. Tried numerous suggestions, nothing worked. Until I found this one:

  • go to the folder userid/Library/Keychains
  • look for a key with the file name from the password request window
  • delete this file (only this one!)
  • try again your app - password is accepted now

Somehow this key was not shown in Keychain Access, like it does not exist. But actual key file was present in keychain folder.

Seems to be some bug in macOS (I am on Sierra) when it can't see key-file, and then another bug - system tries to create a new key-file, but file operation fails (file already exists there). I would suggest to the apple devs to add a proper exception handling there, but I am satisfied for now - problem fixed.

  • Exact error I had, worked perfectly. – Kevin Sep 26 '16 at 17:14
  • Re "not shown"; Is it because you have hidden it in KeyChain (menu View)? – Pacerier Oct 10 '17 at 11:22
  • Click "Show Expired Certificates" and "Show Invisible Items". – Pacerier Oct 10 '17 at 14:36
3

I just disabled FileVault under my System Settings > Security & Privacy last night and let the HD decrypt again and voila, now the keychain works fine again. I had activated it only recently, but had no idea that this would cause such problems and side-effects.

(Other issues with FileVault are probably related, such as Reset Password app in recovery mode not showing and disks)

  • Interesting. I only started using El Capitan (on a brand new MBP) two days ago, and I haven't seen any issues so far with Keychain Access despite what I've read—but I disabled FileVault when installing the OS. I wonder if that is why? (Why I've had no Keychain issues, I mean.) – Wildcard Sep 25 '16 at 20:25
2

A boot into Recovery Mode (Command + R right after reboot) and Disk Utility > First Aid on the main disk solved the problem for me.

  • 1
    But what's the main cause? – Pacerier Oct 10 '17 at 11:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .