1

I just update to tmux 2.1(OS X10.11.3 Terminal.app), and my .tmux.conf(accroding to http://joehanchoi.com/quick-fixes-for-tmux-2-1-on-osx/

set-option -g mouse on
bind -n WheelUpPane if-shell -F -t = "#{mouse_any_flag}" "send-keys -M" "if -Ft= '#{pane_in_mode}' 'send-keys -M' 'select-pane -t=; copy-mode -e; send-keys -M'"  
bind -n WheelDownPane select-pane -t= \; send-keys -M  

but the problem is after I start tmux, the mouse pointer becomes a plus: +, and I cannot copy/paste anymore. And right click on Terminal does not work, no popups

How to solve this?

1

This is happening because you enabled your program to capture and use your mouse inputs so that your terminal app has to forward all mouse events.

However, most terminals have 'override' capability. In most cases holding something like Shift or Ctrl key brings control back to terminal and enables to select text, right-click and make other actions.

I found out that for Terminal app the override key is Fn; for iTerm2 it's Option.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .