0

Recently I was messing around with Backtrack 4r2, and created a USB "live CD" and started from it. I normally run the live CD in a VM, but wanted to see if I could install it on the USB as a separate HDD. Normally, I experiment on VMs as well, but decided to go against my better judgement. This corrupted my startup disk, and for a little bit I had the folder with the question mark. The internal SSD was there untouched, but the starting sequenced was affected. I tried using rEFIt to get back into it, but the system did not recognize the SSD. Finally, I went in with GParted on the live CD, and made the Mac Book Air boot from the "Recovery HD". I used the terminal in the "Recovery HD" to correct my permission, and made the correct area of the SSD my boot disk. I am running Lion 10.7.1, so trying to build a "Recovery USB" was impossible since the app store would only let me access Lion 10.7. Onto the question:

Lion now mounts the "Recovery HD" upon start up, and it didn't before. How can I make it to where it doesn't? As stated, I tried repairing the install, but the App Store only has 10.7, so Lion blocks it as an "older" version.

  • Would superuser be a better place for this question? It is most likely a boot loader problem. – FossilizedCarlos Aug 28 '11 at 0:44
1

this hint suggests

asr adjust --target /dev/disk0s3 -settype "Apple_Boot"

P.S. use diskutil list to confirm that your "Recovery HD" is disk0s3: it should show like this:

$ diskutil list

/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.3 GB   disk0
   1:                        EFI                         209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            499.4 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .