0

Before when I enabled the option to open a new Terminal window from a certain folder, my context menu looked like this:

enter image description here

Now it looks like this:

enter image description here

How can I go back to having just the one option in the context menu? I have tried disabling and reenabling the functionality in System Preferences > Keyboard > Shortcuts > Services to no avail. This appears to have happened after installing SourceTree and I looked around for some options in SourceTree preferences but found nothing so far. What can I do?

1

This is the Services Menu. I assume if you only have a single Service OS X displays this directly.

I find it hard to imagine a computer with only a single Service.

The only option would be to go to the Services Menu in Finder and disable the other services. Of course if you install any software you may get more Services added.

  • The funny thing is, if I disable "New Terminal at Folder" the entire services submenu disappears. I'm really thinking it has something to do with SourceTree but I'd prefer not to uninstall it just because of this... – intcreator Mar 15 '16 at 4:25
  • @brandaemon Not all services are visible. Finder will only display Services which are relevant in the context, and if there are none it will not show. I have SourceTree, but it does not often appear. – Milliways Mar 15 '16 at 4:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .