4

My Finder is broken (OS X 10.9.5). Icon view works fine, but List, Columns, and Cover Flow do not work at all.

When I switch to "List View" (cmd+2), the contents panel of the Finder window does not update. However, if I click around randomly the files will still open. So it is only a problem with the display.

I can revert to Icon View (cmd+1) and it will start working immediately. Related, my desktop icons have the same problem. I can't select icons on my desktop by dragging my mouse, but they are clickable. Relaunching Finder will fix this, but usually stops working very quickly.

I have tried deleting ~/Library/Preferences/com.apple.finder.plist, but it did not help.

What else can I try?

Update:

1) Everything works fine on a Guest account

2) "View as Columns" works as well IF I disable "Show icons" in "View Options". When I check the "Show icons" box it stops working, when I uncheck the box the Finder window starts working again immediately.

Update 2:

My problem seems to be fixed. I applied several System Updates (through Software Update) which seems to have caused some settings to be reset. At that point, my problem was 99% fixed; List View worked but was still a bit buggy (some of the "expand" arrows were missing). I followed the instructions from this page (posted below for convenience), and now it seems to be 100% back to normal for now.

Delete icon cache files:

$ sudo find /private/var/folders/ -name com.apple.dock.iconcache -exec rm {} \;

$ sudo find /private/var/folders/ -name com.apple.iconservices -exec rm -rf {} \;

$ sudo rm -rf /Library/Caches/com.apple.iconservices.store

  • Did you kill Finder after deleting the plist? – nohillside Mar 14 '16 at 19:05
  • Yes. When I relaunch Finder, everything works fine for the first window I open. If I try to navigate to a different folder, it breaks until I relaunch again or switch to Icon view. – Jeff Mar 14 '16 at 19:08
  • If it's always the same folder which causes troubles: Is there a .DS_Store in it? – nohillside Mar 14 '16 at 19:11
  • It is all folders. I have tried deleting .DS_Store for one folder to see if it made a difference, but no luck – Jeff Mar 14 '16 at 19:12
  • I just tried creating a Guest account, and Finder appears to work almost fine in the Guest account. Are there any other files that govern user preferences for Finder windows? – Jeff Mar 14 '16 at 19:20
6

I had this problem following upgrades to Google Drive on 29 July 2016.

To fix it I had to

  1. Change Google Drive settings to 'Show sync file status items and right click menu' (in Advanced tab)

  2. Restart the Finder.

Of course the setting no longer worked, but you can see if you are synced from the Google Drive menu in the top bar.

  • Shouldn't #1 instruct the user to "uncheck" that setting? Disabling it is what fixed the problem for me. As it reads currently it sounds like you are telling people to enable it. – Colin Marshall Sep 8 '16 at 0:47
2

Do you have Google Drive installed on your system?

I've been having the same issue for a couple of days now and I've been trying various things. I upgraded to OS X 10.9.5 (from 10.9.4), uninstalled and reinstalled TotalFinder, etc. But I could still execute a certain pattern of movements which would crash my Finder and Desktop.

But now as I was looking through the logs, I found something interesting in there.

2016/03/17 12:03:32.639 Google Drive[300]: 2016-03-17 12:03:32.638 Google Drive Icon Helper[11796:507] Inject result: 0
2016/03/17 12:03:32.665 Finder[11401]: Loading Google Drive Finder extension
2016/03/17 12:03:32.667 Finder[11401]: Pipe path is a symbolic link, connecting to target.
2016/03/17 12:03:32.667 Finder[11401]: ~/Library/Application Support/Google/Drive/GoogleDriveIpcPipe is a symbolic link to /var/folders/t4/jv71dmbs54zgq64md4_bw7h80000gn/T/tmpD5Ruy9, connecting to link target.
2016/03/17 12:03:37.612 Finder[11401]: Pipe path is a symbolic link, connecting to target.
2016/03/17 12:03:37.612 Finder[11401]: ~/Library/Application Support/Google/Drive/GoogleDriveIpcPipe is a symbolic link to /var/folders/t4/jv71dmbs54zgq64md4_bw7h80000gn/T/tmpD5Ruy9, connecting to link target.
2016/03/17 12:03:42.219 Finder[11401]: -[OverlayCache isPathInGdrive:]: unrecognized selector sent to instance 0x7fe5aa65a500
2016/03/17 12:03:42.219 Finder[11401]: -[OverlayCache isPathInGdrive:]: unrecognized selector sent to instance 0x7fe5aa65a500
2016/03/17 12:03:42.221 Finder[11401]: (
    0   CoreFoundation                      0x00007fff8c66325c __exceptionPreprocess + 172
    1   libobjc.A.dylib                     0x00007fff958d3e75 objc_exception_throw + 43
    2   CoreFoundation                      0x00007fff8c66612d -[NSObject(NSObject) doesNotRecognizeSelector:] + 205
    3   CoreFoundation                      0x00007fff8c5c1272 ___forwarding___ + 1010
    4   CoreFoundation                      0x00007fff8c5c0df8 _CF_forwarding_prep_0 + 120
    5   FinderExt                           0x0000000111de41f7 -[NSImageView(IconOverlayHandlers) IconOverlayHandlers_drawRect:] + 256
    [...]
    47  libdyld.dylib                       0x00007fff8f3675fd start + 1
    48  ???                                 0x0000000000000001 0x0 + 1
)
2016/03/17 12:03:42.224 Finder[11401]: +[CATransaction synchronize] called within transaction

Google Drive Icon Helper does some icon injection right before Finder crashes because of the list view. And since I was beginning to be quite desperate, I decided to run killall Google\ Drive through Terminal to see what would happen; I can no longer crash Finder and Desktop through the steps that crashed it before.

This being a rogue Google Drive Finder injection would also explain why I've been having this issue for roughly the same amount of time as you: Google Drive executes auto updates, so the broken update would be installed on our computers around the same time. Unfortunately I can't find any changelogs for the Google Drive OS X application, so I cannot actually verify if such an update has been pushed.

But if you don't have Google Drive installed, then perhaps this is not the actual fix for my Finder issues or my issue is separate from yours.

  • Interesting! I looked at my sys log and my crashes were also due to Google Drive. Although since my updates, I haven't had any problems and I am still running Google Drive. – Jeff Mar 18 '16 at 1:21
  • Same crashlog for me. Uninstalled Google Drive and now finder works. Thank you, I though my HD was donezo! – typeoneerror Aug 18 '16 at 15:08
0

In the old days (OS X 10.6 and lower) it was fine to remove a .plist file, but now that the preferences database exists primarily in memory and database files that persist to disk. Especially with apps like Finder that will overwrite and flush the current changes to disk and override your filesystem changes to the static plist - it would be better to use other methods to troubleshoot Finder.

  1. Make a new user account and verify that the issue persists there
  2. Use the defaults command to read/write/delete keys in the user defaults database directly as opposed to manipulating the file itself.

If the issue persists to the new user - it's likely filesystem corruption or a bug to escalate to engineering. If the issue does not persist, a restart of the entire OS will let you know if the issue is runtime corruption (perhaps influenced by your main user settings) or something that crops up over time.

Also - going over any finder extensions, programs that run continuously and third party kernel extensions (FUSE, haxies, skins and the like) would be worth inventorying and disabling. A safe boot might help with that as a first triage step.

Lastly, keeping a log of when this happens and running sysdiagnose each time you notice it will help with collecting logs and diagnostics if you can't find an easy solution and want to look over the system logs or escalate this to Apple or another resource.

  • It seems to work in Guest mode (in my brief test). I'm not sure what "use defaults" means... I have run sysdiagnose but I don't know what to do with the results. Restart does not help. – Jeff Mar 14 '16 at 19:41
  • Without a pointed question about sysdiagnose it's likely too broad to answer what it does. For this case, it dumps a file in /var/tmp so you can have a history of how quickly after a restart the issue happens. If you wanted to clear all finder defaults - defaults delete com.apple.finder should do the trick. You could be more fine grained if you wished, too @Jeff – bmike Mar 14 '16 at 20:16
  • Thanks bmike. I just discovered "View as Columns" works as well IF I disable "Show Icons" in "View Options". If I check "Show Icons" it freeze, if I uncheck it it starts working again immediately. – Jeff Mar 14 '16 at 20:26
  • @Jeff GRR - your launch services / icon cache subsystem are likely in confusion or worse. – bmike Mar 14 '16 at 21:05
0

I had the same problem with a bunch of console errors like:

30/03/2016 12:40:14.693 pm Finder[69282]: Pipe path is a symbolic link, connecting to target.
30/03/2016 12:40:14.693 pm Finder[69282]: /Users/<user>/Library/Application Support/Google/Drive/GoogleDriveIpcPipe is a symbolic link to /var/folders/y6/_0g8ddpn1yvf12fg_1zrn9vr0000gn/T/tmpKKz7iI, connecting to link target.

While I'm sure killing the Google Drive process would work, I wanted to keep it around so I started digging in the preferences. Turns out my problem was caused by the system setting "Show file sync status icons and right click menu". Hopefully disabling that works for you.

0

Boot up on a different System disk, then delete ~/Library/Preferences/com.apple.finder.plist on your usual disk. Reboot to usual. If you don't have a spare drive, buy one. They're down to about $60 a Terabyte. You can use it for backups. If you get permission errors, you'll have to fix them before proceeding.

You must log in to answer this question.

protected by Community Aug 25 '16 at 9:50

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .