2

Using disk utility, I was erasing and re-formatting to FAT. During that process, the usb cable was removed. Now, the hard drive will not format. When recognizing the hard drive, a window shows up stating "The disk you inserted was not readable by this computer" with the options to "initialize; ignore; eject." "Initialize" does not seem to do anything. Disk Utility shows the physical drive, but no sub folder (volume?) When attempting to erase and create a new partition, I get an error. The disk was already empty, so I'm not worried about retrieving files, but is the drive itself physically damaged?

screen shot

  • Welcome to the site. If you disconnect the drive and quit Disk Utility - do you see the same window with "Erase" as the option you can choose? Also - what is the specific error you received? It can usually be seen in system.log and perhaps some other log files recently modified in /var/log folder or the console app. – bmike Mar 13 '16 at 22:12
  • Improperly disconnecting a drive, especially during a write process, has the potential to damage it, although most likely just the filesystem not the physical platters. If Disk Utility will not allow you to process the drive then I'd do as suggested by jan.h however make absolutely sure the of option of the dd command is pointing to the correct disk! – user3439894 Mar 14 '16 at 0:58
1

You could try overwriting the partition table with zeros. To do so, enter sudo dd if=/dev/zero of=/dev/disk3 bs=1m count=1 in a Terminal window. This will overwrite the first megabyte of the drive with zeros, which will include (and thus erase) the partition table (or its remnants). Remove and re-insert the drive; if everything goes well it will tell you that the disk was not readable and it'll offer to initialise the disk. (I tried this with an old USB stick a minute ago and it worked fine.)

  • Thank you all for the responses! I tried this, and I made sure of pointed to the correct disk. When plugged in, it offers to initialize, but that still doesn't seem to do anything. In Disk Utility, I attempted to Erase and Format in FAT, with the scheme: "Master boot record." This returns an error stating: "Unmounting disk. Unable to write to the last block of the device. Operation failed..." – Chris Girouard Mar 16 '16 at 2:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .