If you disconnect a removable drive without ejecting it first, the next time you connect it, Windows or Mac run an fsck check on the disk to ensure data integrity. Windows will ask if you want to check for errors, OS X does it invisibly.

USB3 disks often disconnect inexplicably in OS X. If the disk hasn't been used for hours I know there is no issue. On Windows, I can simply decline to run the check. On OS X I just have to sit waiting for 30 minutes while the fsck thrashes my disk. This happens daily, so OS X will rapidly kill my hard drive. (This paragraph has been edited since the answers were posted.)

How can I disable this check? Can I connect via a non-native driver? Can I run something to flip the flag on the disk that tells OS X the disk was improperly disconnected? Can I change disk format? Can I disable whatever it is that sets the flag 'improperly disconnected' when I connect the drive, that is then unset on proper ejection? I'm desperate, as the Mac has a tiny hard disk and now I can't use externals. Any direction, no matter how hacky or improper, gratefully received! I have tried accessing the drive through Windows in VirtualBox or Parallels, but they can't see the drive until OS X has stopped fsck.

I believe File System State is the state/setting I need to ignore/override.

The disk is exFat with Master Boot Record, and OS X is 10.11.3. Update: this has now happened on the other USB socket with a flash disk (I'd only seen this on an HDDs that report themselves as non-removable before).

There isn't an Apple repair centre in the country I live in, the disk isn't used for frequently accessed files, I would do a check if there was a chance of corruption (ie, a disconnection during or shortly after a write to the disk), and I've always declined the check in Windows (for decades) because the only time I've had a corruption is from the check itself.

  • 4
    I force-kill fsck_exfat from Activity Monitor. I've filed an issue with Apple that they don't provide any visual indication that this process is running. I suggested to them that they display the disk greyed out with a progress-circle overlay.
    – P i
    Commented Oct 10, 2019 at 11:30
  • much love, you've saved me thousands of dollars. It took me months to realize this was a fsck_exfat issue - after. two years I can open my HD again
    – Jonca33
    Commented Feb 7, 2021 at 2:37

1 Answer 1


Open Terminal and enter:

#Get the disk identifier of the ExFAT partition
diskutil list
#Get the UUID of the ExFAT volume with diskXsY being its disk identifier
diskutil info /dev/diskXsY
#Create and edit /etc/fstab 
sudo vifs

Add a line with the following content after activating insert mode (e.g with I)

#Replace the UUID below by the one found earlier!
UUID=2FECDB7A-15F0-36F9-9A47-483B9669D6DC none exfat rw,auto 0 0

Hit esc to leave insert mode. Enter :w! to write the file to disk and :q to quit vifs.

Reboot your Mac.

The last 0 should disable fsck.

An alternative method may be: rename /sbin/fsck_exfat to /sbin/fsck_exfat.paralyzed with:

sudo mv /sbin/fsck_exfat /sbin/fsck_exfat.paralyzed

Since /sbin/fsck_exfat is a link only you may also have to rename the original file: /System/Library/Filesystems/exfat.fs/Contents/Resources/fsck_exfat.

Both methods are not recommended! Instead the USB socket should be repaired.

  • 1
    @Chris After renaming the file(s) you can re-enable SIP! After updating OS X the files may be replaced by newer versions though!
    – klanomath
    Commented Mar 15, 2016 at 17:14
  • 1
    @Chris I have a lot of external disks (FW/USB2/USB3) and I never encountered any problem with OS X. I use GUID/OSX Journaled consistently though. It really depends on the external disk's firmware and the controller chip (USB->SATA) and the quality of the cable.
    – klanomath
    Commented Apr 9, 2016 at 14:39
  • 1
    @ klanomath I think journaled is the answer! I no longer get the "disconnect first" error, I can disconnect and reconnect frequently and OS X is fine even if I don't eject, I can connect via USB2, 3, via 2 hubs no problem. I wouldn't even notice a brief disconnect. I work with Windows and Ubuntu users so I'll have to carry a drive with Paragon HFS+ for colleagues etc. Just installed a Parallels Access trial to try NTFS, but I suspect it's not near-kernel/native. ENORMOUS thanks @klanomath I really can't thank you enough for dragging me through this, this is an absolutely emormous relief.
    – Chris
    Commented Apr 9, 2016 at 22:42
  • 2
    @CanPoyrazoğlu unfortunately I never found a way to disable the check, or the intermittent disconnections. Even bought a brand new Mac and it still disconnects disks randomly then churns away when I reconnect. Only 'solution' was to use only journalled disks so at least there isn't a massive delay while the disk checks itself. But stuff which is sensitive to even microsecond disconnection, like Docker on external disks, just doesn't work on macOS. It's shocking really that such a fundamental thing is left broken.
    – Chris
    Commented Nov 5, 2018 at 13:40
  • 4
    @Chris while I understand Apple wants everything to be 'under control' and stable, I wish they at least provided a way, even if disabled by default, to skip check for the power users. Commented Nov 5, 2018 at 17:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .