I know this has been asked a zillion times and there are many search results all over the web. However, I have never found any answer that actually fixes the problem.

So, to restate: I have an iPhone 5C (model 1532) with 8G (says 5 available). I'm running IOS 9.2.1. My storage says I have 0 bytes available, and I can't do anything that changes it. I've tried a reset (power+home). It says I have 180M in photos, however I did go delete a bunch and the number didn't change. I don't have iTunes, it's not connected to a PC, I don't have music or videos on it.

How can I free up space? How can I delete files (pictures, apps) and have the system acknowledge the change? This is seriously frustrating that I can't manage the space usage on the device.

  • 1
    Did you remove the photos from within the Trash in Photos as well? If yes, can you please add a screenshot of your storage screen.
    – nohillside
    Commented Mar 11, 2016 at 15:46
  • Ok, I admit I didn't know I could/had to go permanently delete them from the trash. However, that gave me 44M, and that went away when I tried apply waiting app updates. Also, I've removed some apps to try to free up space, and that isn't reclaimed either. I assume apps don't have a trash?
    – end-user
    Commented Mar 11, 2016 at 16:08
  • No, apps don't have a Trash. But 8 GB is rather small anyway, your storage settings screen should show how much space is taken by each app.
    – nohillside
    Commented Mar 11, 2016 at 16:09
  • Yes, it does. So, I painstakingly added up all the apps' space allocations, and it comes to 2.218G. If I have 5 available, where's the other 2.8G being used up? And, I'm assuming the 8G model gives over 3 to the OS?
    – end-user
    Commented Mar 11, 2016 at 16:16
  • There are some similar questions already here, see the Related column at the right.
    – nohillside
    Commented Mar 11, 2016 at 18:27

3 Answers 3


For anyone else in this situation, I'm posting my experience. I did install iTunes and do a backup/restore, but that didn't fix it. It did help me see that, in fact, there was a huge chuck of data marked as "other" - this is what most forum posts describe. I began deleting apps to see if I could figure out which was responsible, but nothing reduced that wasted space. Finally, I was forced to accept the unpleasant reality. Yes, you have to wipe your phone. Since I had a backup, I went to Settings -> General -> Reset (at the bottom) -> Erase All Content and Settings. After, I used iTunes to do a restore. This brought back pretty much everything the way I had it. However, apps that I deleted I had to search and reinstall from the AppStore. (Why don't they have a "my apps" list like Amazon does?)

  • 1
    Um, there’s “purchased items” (or whatever the actual term is in English). It includes free apps.
    – Crissov
    Commented Mar 21, 2016 at 15:05
  • Ah yes, I see that now. It's under "updates".
    – end-user
    Commented Mar 21, 2016 at 15:52

If you have any partially downloaded app, large file etc. which has not been removed, this can occur. Clear cache or delete partially downloaded large file and that resolve your problem. A quick glance on how to clean the cache in an iPhone.

  1. Tap Settings app → General → iPhone Storage. (On an iPad that option will be labelled iPad Storage.)

  2. At the bottom of the screen you'll see your apps, arranged by the amount of storage they take up.

  3. Tap an app that's taking up a lot of space (In this case application download data and store them in a location of the iPhone).

  4. Take a look at the entry for Documents & Data. If it's using more than 500MB, it's worth deleting and reinstalling the app to clear the space. Tap Delete App (Note: This will delete any user data associated with the app, so proceed with caution).


Don't worry. There are several questions for you: Have you updated your iPhone to latest iOS version? Have you checked your "Recently deleted" album and deleted them? Have you installed the app "WhatsApp"? Seems it was the app "WhatsApp", creating lots of cache files and stealing storage from the phone. You can try to install the update and see whether the storage came back to a normal level. Also you can read this thread that someone who has similar problem with you. Hope it helps!

  • Yes, latest version (9.2.1 as stated). Yes, recently deleted has been cleared. No, WhatsApp not installed. Read the thread - no actual solution was presented.
    – end-user
    Commented Mar 21, 2016 at 14:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .