2

When setting up a new IMAP account in Apple Mail 9.2, it gives me no option to specify the incoming and outgoing ports, not SSL options. See screenshot below.

The ability to do this would be most helpful as some mail accounts do vary from the norm in terms of default ports and SSL. When I do fill in all the fields asked for, I get the spinning progress animation for a long time before it gives up with an error (shown). I have no idea if it had tried several different ports (including the ones I want to use) or if it just kept retrying on the same (wrong settings).

Other email clients give the option to set the ports. At the moment I don't have these available and need to use Apple Mail.

New account setup

4

OK... this is irritating, but possible... you used to be able to force it to ignore at that point, then set it up manually from the Accounts pane.

The El Capitan version looks like you need to do that initial setup from System Prefs > Internet Accounts, rather than directly in Mail itself.

Start from the right pane - 'Add Other Account...' [scroll down to see it, for some reason the + - buttons are unclickable. If you do, they grey out]
then Mail Account.

You get a very similar dialog as in your question - fill it in as before.
It will error, as before - the major difference being that 'Sign In' changes to 'Next'

& you're in... hit Next & select Mail &/or Notes & Done.
Close the Prefs.

If Mail is open, quit & relaunch.

Mail prefs/Accounts now has the bare bones of your new account, from which you can manually set up all the necessary ports, using the Advanced tab for incoming prefs & the still rather annoying Outgoing Mail Server (SMTP) drop menu for outgoing.

2
  • Accepted, for advising to go through Preferences, when I went that way, it didn't ask for the port but it did work. Mar 11 '16 at 12:00
  • Yes - it doesn't ask for the port, but it does let you get past the 'sign up' blockage. The rest is as it used to be, a manual setup in Mail prefs.
    – Tetsujin
    Mar 11 '16 at 12:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .